summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-15 14:56:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-15 15:20:04 +0200
commit79b15a0228e634e9418706ff8b27d21ced8ba0ee (patch)
tree80767f709835674ad07d830d94027ff88bde8f7c /media-sound/mpd
parentdev-libs/expat: 2.2.6 (diff)
downloadgentoo-79b15a0228e634e9418706ff8b27d21ced8ba0ee.tar.gz
gentoo-79b15a0228e634e9418706ff8b27d21ced8ba0ee.tar.bz2
gentoo-79b15a0228e634e9418706ff8b27d21ced8ba0ee.zip
media-sound/mpd: Fix build with >=dev-libs/libcdio-2
Closes: https://bugs.gentoo.org/641078 Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'media-sound/mpd')
-rw-r--r--media-sound/mpd/files/mpd-0.20.10-libcdio-2.patch27
-rw-r--r--media-sound/mpd/mpd-0.20.10.ebuild1
-rw-r--r--media-sound/mpd/mpd-0.20.12-r2.ebuild5
3 files changed, 32 insertions, 1 deletions
diff --git a/media-sound/mpd/files/mpd-0.20.10-libcdio-2.patch b/media-sound/mpd/files/mpd-0.20.10-libcdio-2.patch
new file mode 100644
index 000000000000..9153a87dcf9d
--- /dev/null
+++ b/media-sound/mpd/files/mpd-0.20.10-libcdio-2.patch
@@ -0,0 +1,27 @@
+From 12fd1cad0cc5472cbe931516970c1ac7aeb7ec00 Mon Sep 17 00:00:00 2001
+From: Max Kellermann <max@musicpd.org>
+Date: Sat, 3 Feb 2018 19:32:31 +0100
+Subject: [PATCH] archive/iso9660: libcdio 2.0 compatibility
+
+Closes #173
+---
+ src/archive/plugins/Iso9660ArchivePlugin.cxx | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/archive/plugins/Iso9660ArchivePlugin.cxx b/src/archive/plugins/Iso9660ArchivePlugin.cxx
+index 536745d85..363921527 100644
+--- a/src/archive/plugins/Iso9660ArchivePlugin.cxx
++++ b/src/archive/plugins/Iso9660ArchivePlugin.cxx
+@@ -115,7 +115,12 @@ Iso9660ArchiveFile::Visit(char *path, size_t length, size_t capacity,
+ visitor.VisitArchiveEntry(path + 1);
+ }
+ }
++
++#if LIBCDIO_VERSION_NUM >= 20000
++ iso9660_filelist_free(entlist);
++#else
+ _cdio_list_free (entlist, true);
++#endif
+ }
+
+ static ArchiveFile *
diff --git a/media-sound/mpd/mpd-0.20.10.ebuild b/media-sound/mpd/mpd-0.20.10.ebuild
index f6cea8f7ebd7..e5b9f541a62f 100644
--- a/media-sound/mpd/mpd-0.20.10.ebuild
+++ b/media-sound/mpd/mpd-0.20.10.ebuild
@@ -100,6 +100,7 @@ RDEPEND="${CDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-0.18.conf.patch
+ "${FILESDIR}"/${P}-libcdio-2.patch
)
pkg_setup() {
diff --git a/media-sound/mpd/mpd-0.20.12-r2.ebuild b/media-sound/mpd/mpd-0.20.12-r2.ebuild
index 85119e9eebe7..78b954370d78 100644
--- a/media-sound/mpd/mpd-0.20.12-r2.ebuild
+++ b/media-sound/mpd/mpd-0.20.12-r2.ebuild
@@ -105,7 +105,10 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-mpd )
"
-PATCHES=( "${FILESDIR}"/${PN}-0.18.conf.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.18.conf.patch
+ "${FILESDIR}"/${PN}-0.20.10-libcdio-2.patch
+)
pkg_setup() {
use network || ewarn "Icecast and Shoutcast streaming needs networking."