summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-16 07:02:43 +0000
committerSam James <sam@gentoo.org>2022-05-16 19:56:40 +0000
commit7527905c4777bb0c1afe4336bfd963a269463722 (patch)
treed823f86e4447141787130584a4521ee8cdcfdf47 /net-analyzer/cacti-spine
parentnet-analyzer/cacti: add 1.2.20 (diff)
downloadgentoo-7527905c4777bb0c1afe4336bfd963a269463722.tar.gz
gentoo-7527905c4777bb0c1afe4336bfd963a269463722.tar.bz2
gentoo-7527905c4777bb0c1afe4336bfd963a269463722.zip
net-analyzer/cacti-spine: add 1.2.20
Bug: https://bugs.gentoo.org/834597 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 30385882f72e..80deba0f5188 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-1.2.17.tar.gz 110371 BLAKE2B 1f9605d34fcff0e4e7921ccbb5a22eeb9e2f2e2f22cf56189790dcdec798db5bff681df11cd82006254cc270174248c07ce3d94dca8d3367add6b220f1599adf SHA512 4c616af041d2f08e18fd274409c98d3efce84b7cca2d6e23db3d6c2a0d4c9a77a2c52c0ef8e0ed0c6ad409f28b56fdf3160e27654522d8aeb1b88e3cb4128d4a
DIST cacti-spine-1.2.19.tar.gz 113974 BLAKE2B 6ec71e1480e9dfd2636c61bcea10c6581009908334fddbaab5cf4bf6948bc6f8ffb27b0325ab1f325b9ad0b0f2ba7e018373c34534ca5d4967f66100fba76934 SHA512 407a4e83aabaa62693c2f7c3d3952da9178bb28e2b8b914a5649e3eaccb9ea77d0c7db8e251a113a308bfaaa0674be941abfb2fc4f8e50d43fb73c8cd9deec63
+DIST cacti-spine-1.2.20.tar.gz 115258 BLAKE2B 78a9ed8a9e7e69e98bfa9971134dd6f34f540a93b0b1a2aababb66781f3c9787712d57d86b81d7f409487c4cc4447d4f84bd7292890b7eb70ec4137d97248793 SHA512 d7e129f7b42542d7ecc78d55cebc6d9ce481834342d3f3da1fce5538d8e42bc194a825795053d5e3a065b54574e2a3b9413725f1bc0562e55f1db213f9a94d0c
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
new file mode 100644
index 000000000000..a8ac30938351
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-db/mysql-connector-c:=
+ dev-libs/openssl:=
+ net-analyzer/net-snmp:="
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
+BDEPEND="sys-apps/help2man"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Drop CONFIG_SHELL after 1.2.x (fix is on develop branch)
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}