summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-04-09 20:37:55 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-04-09 20:40:01 -0500
commit90c16e98268b8fa361a9d518d13d47e38e68c5cb (patch)
treeddc76f20649ff9afacead818c131f0f3bd4082f3 /net-analyzer
parentllvm.eclass: modernise Clang versions in example (diff)
downloadgentoo-90c16e98268b8fa361a9d518d13d47e38e68c5cb.tar.gz
gentoo-90c16e98268b8fa361a9d518d13d47e38e68c5cb.tar.bz2
gentoo-90c16e98268b8fa361a9d518d13d47e38e68c5cb.zip
net-analyzer/pmacct: add 1.7.6
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pmacct/Manifest1
-rw-r--r--net-analyzer/pmacct/files/pmacct-1.7.6-nogit.patch16
-rw-r--r--net-analyzer/pmacct/pmacct-1.7.6.ebuild98
3 files changed, 115 insertions, 0 deletions
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index 2fc46c924bd6..53825a919878 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -1 +1,2 @@
DIST pmacct-1.7.5.tar.gz 3219384 BLAKE2B 9a9feb8a11222e54a018b37eaa387cfa43efcb6aa3da175ea6c367bc7b42d816cbe106431c8b8f69b17c8d0286514a80250bf28b15fcaad12a2ac5fb7af6ff27 SHA512 d52e3d749cf0e8a412a82051531c63f37aa6cf4e7cc435ebd185195040819d65dc2cf4d4b1aa64bae620a9f8d3d1b1a505992044fe45d57b91ba056cfa67609c
+DIST pmacct-1.7.6.tar.gz 2126837 BLAKE2B df04822e88f9409d335457031fb26ce4ae8b5da13cf2f55f8d6c78eb50dade62ef763d389ac81a509d9351e12844446ac73171e9966a5aeeecc0e5fb10219c73 SHA512 b370d20f8b8d49b9114db3ab74c66cd16962dee5e7c3642fab0b2787c4ea924a249ff4d8d770c0ccc8ca81366b9a5e557dcfb7cdddf878b99b719d0accdb949a
diff --git a/net-analyzer/pmacct/files/pmacct-1.7.6-nogit.patch b/net-analyzer/pmacct/files/pmacct-1.7.6-nogit.patch
new file mode 100644
index 000000000000..7381408d4489
--- /dev/null
+++ b/net-analyzer/pmacct/files/pmacct-1.7.6-nogit.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+index 34269bd9..c6dbe8ba 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1140,10 +1140,7 @@ dnl Git submodule Dependencies buid system
+ dnl --------------------------------------
+
+ dnl First check whether to build git submodule deps
+-WITH_EXTERNAL_DEPS_DEFAULT=yes
+-if [ test ! -f "$srcdir/src/external_libs/libcdada/include/cdada.h" ] && [ test -z `git rev-parse HEAD 2> /dev/null` ]; then
+- WITH_EXTERNAL_DEPS_DEFAULT=no
+-fi
++WITH_EXTERNAL_DEPS_DEFAULT=no
+
+ AC_MSG_CHECKING([whether external dependencies (git submodules) should be compiled])
+ AC_ARG_WITH(external-deps,
diff --git a/net-analyzer/pmacct/pmacct-1.7.6.ebuild b/net-analyzer/pmacct/pmacct-1.7.6.ebuild
new file mode 100644
index 000000000000..3cebdfe03e0a
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-1.7.6.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="A network tool to gather IP traffic information"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="
+ +bgp-bins +bmp-bins geoip geoipv2 jansson kafka +l2 mysql ndpi nflog
+ postgres rabbitmq sqlite +st-bins +traffic-bins zmq
+"
+REQUIRED_USE="
+ ?? ( geoip geoipv2 )
+ kafka? ( jansson )
+ rabbitmq? ( jansson )
+"
+
+RDEPEND="dev-libs/libcdada
+ net-libs/libpcap
+ geoip? ( dev-libs/geoip )
+ geoipv2? ( dev-libs/libmaxminddb )
+ jansson? ( dev-libs/jansson )
+ kafka? ( dev-libs/librdkafka )
+ mysql? (
+ dev-db/mysql-connector-c:0=
+ sys-process/numactl
+ )
+ ndpi? ( >=net-libs/nDPI-3.2:= )
+ nflog? ( net-libs/libnetfilter_log )
+ postgres? ( dev-db/postgresql:* )
+ rabbitmq? ( net-libs/rabbitmq-c )
+ sqlite? ( =dev-db/sqlite-3* )
+ zmq? ( >=net-libs/zeromq-4.2.0:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.4--Werror.patch"
+ "${FILESDIR}/${PN}-1.7.6-nogit.patch"
+)
+
+DOCS=(
+ CONFIG-KEYS ChangeLog FAQS QUICKSTART UPGRADE
+ docs/INTERNALS docs/PLUGINS docs/SIGNALS
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC AR RANLIB
+ append-cflags -fcommon
+
+ econf \
+ $(use_enable bgp-bins) \
+ $(use_enable bmp-bins) \
+ $(use_enable geoip) \
+ $(use_enable geoipv2) \
+ $(use_enable jansson) \
+ $(use_enable kafka) \
+ $(use_enable l2) \
+ $(use_enable mysql) \
+ $(use_enable ndpi) \
+ $(use_enable nflog) \
+ $(use_enable postgres pgsql) \
+ $(use_enable rabbitmq) \
+ $(use_enable sqlite sqlite3) \
+ $(use_enable st-bins) \
+ $(use_enable traffic-bins) \
+ $(use_enable zmq) \
+ --without-external-deps \
+ --disable-debug \
+ --disable-mongodb
+}
+
+src_install() {
+ default
+
+ for dirname in examples sql telemetry; do
+ docinto ${dirname}
+ dodoc -r ${dirname}/*
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd
+
+ insinto /etc/pmacctd
+ newins examples/pmacctd-imt.conf.example pmacctd.conf
+}