summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-06-25 16:00:22 +0100
committerSam James <sam@gentoo.org>2021-06-29 05:52:15 +0100
commit289aa33277dcba453d0c2519c49ad947f4ea504a (patch)
treee496703f866d95cb2e415df56b135524818715e0 /net-irc/ergo
parentmedia-video/libva-utils: bump to v2.12.0 (diff)
downloadgentoo-289aa33277dcba453d0c2519c49ad947f4ea504a.tar.gz
gentoo-289aa33277dcba453d0c2519c49ad947f4ea504a.tar.bz2
gentoo-289aa33277dcba453d0c2519c49ad947f4ea504a.zip
net-irc/ergo: Fixed OpenRC init script to handle backgrounding correctly and added reload function.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/21425 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc/ergo')
-rw-r--r--net-irc/ergo/ergo-2.7.0-r1.ebuild (renamed from net-irc/ergo/ergo-2.7.0.ebuild)0
-rw-r--r--net-irc/ergo/files/ergo.initd10
2 files changed, 9 insertions, 1 deletions
diff --git a/net-irc/ergo/ergo-2.7.0.ebuild b/net-irc/ergo/ergo-2.7.0-r1.ebuild
index edff5c53fda6..edff5c53fda6 100644
--- a/net-irc/ergo/ergo-2.7.0.ebuild
+++ b/net-irc/ergo/ergo-2.7.0-r1.ebuild
diff --git a/net-irc/ergo/files/ergo.initd b/net-irc/ergo/files/ergo.initd
index bc2b7dd064d1..025d6951862b 100644
--- a/net-irc/ergo/files/ergo.initd
+++ b/net-irc/ergo/files/ergo.initd
@@ -1,6 +1,8 @@
#!/sbin/openrc-run
command=/usr/bin/ergo
-command_args="--conf ${ERGO_CONFIGFILE:-"/etc/ergo/ircd.yaml"}"
+command_args="run --conf ${ERGO_CONFIGFILE:-"/etc/ergo/ircd.yaml"}"
+command_background=true
+extra_started_commands="reload"
pidfile=/var/run/ergo.pid
name="ergo"
description="ergo IRC daemon"
@@ -9,3 +11,9 @@ depend() {
use dns
provide ircd
}
+
+reload() {
+ ebegin "Reloading ${RC_SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $?
+}