summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-06 14:56:39 -0600
committerFlorian Schmaus <flow@gentoo.org>2024-06-07 09:35:46 +0200
commit89f7ce613a3d17049d6f0db45a2c8eb5f596148f (patch)
treeb3c08065d46f3c54e86af49bc48a24cc6c7bbba5 /net-irc
parentmedia-radio/gpredict: add 2.3_p20231224, 9999 (diff)
downloadgentoo-89f7ce613a3d17049d6f0db45a2c8eb5f596148f.tar.gz
gentoo-89f7ce613a3d17049d6f0db45a2c8eb5f596148f.tar.bz2
gentoo-89f7ce613a3d17049d6f0db45a2c8eb5f596148f.zip
net-irc/weechat: add 4.3.2
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/37061 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/Manifest2
-rw-r--r--net-irc/weechat/weechat-4.3.2.ebuild190
2 files changed, 192 insertions, 0 deletions
diff --git a/net-irc/weechat/Manifest b/net-irc/weechat/Manifest
index f8b3dc1f8321..3db37d40e822 100644
--- a/net-irc/weechat/Manifest
+++ b/net-irc/weechat/Manifest
@@ -6,3 +6,5 @@ DIST weechat-4.2.3.tar.xz 2594708 BLAKE2B d36e4a0041d5fa9533f82b5c3abe3286b5805f
DIST weechat-4.2.3.tar.xz.asc 833 BLAKE2B 3a973ca88f95f2b231f49f394f9214343b2b9bfb76a76cc2173543a7e3472321489daaae939f47053ff55f52b7e2d9feca8e418c695460fa8a15bd0f3fa3c477 SHA512 9f8df247be019d797bff244ef9337667e2d61a93ea68fc78abeb48f3a1414b307fd0e137b2d9a473ced5c9ba2518fc012f4cadeed041605f3a30d04d54fec7b7
DIST weechat-4.3.1.tar.xz 2692548 BLAKE2B 5072bea7375802bfac1522ab97058f12705834525c27e7bf4f69d0ae3e51076755e622cb4cf121324e9bbab3da11b776127a26ea5a583803b613902f78c36d16 SHA512 e78fb37f983600340c88d63b5ba4e26febb18184c71da396daf8af6539a09c23656f6c8984d9ccb65cd5ec8fad099c4492111167870fbf9718088e7e9e5f556d
DIST weechat-4.3.1.tar.xz.asc 833 BLAKE2B 1412d40e9f6950d6c8cfe51ea5ecd4423aa1e86d0aa522017d3af065c4aa64ed816c4bd8af701f1a8859c511b3b85377c22b7cf4f59a8ef2cfa44eb0abe0dada SHA512 358b41e4c27e1c32ed1c8c20fd4487c9445ea203cd76fb77c8a082baad38105c0e93a8aabb656680a0d429e76a26bb149f2f2b6a4eda4b8192f1520a9249458a
+DIST weechat-4.3.2.tar.xz 2693508 BLAKE2B 599ee64317f2a10c7bdd8636759b249d3db7c4c30bc9c12566e4dc2534ec932fa8f3b2fe1c570e2e40b20cac9af99f8429ee1bf6edc0aa2c7e32368058f515c6 SHA512 438d76cada9bb870c188b8fe0c8ad45d1d0dc71392ee8d5193c5b3c3424afad4f98bedc9a396b2294c4cb20bce9299e5a4f921525f7f976e5cd1f589a78b2caa
+DIST weechat-4.3.2.tar.xz.asc 833 BLAKE2B 14a71a4b66cf82fe7bb0e3c7eefe3f2f3d3b14f0c7ca26fd645716d33acd64598dfcfda9162bb07290cb9758eeef1471cde28183c559440597d45bc8984969a6 SHA512 ff9a3d3777fecf1de1898647b97f45ebe68c95f09cc098280ba4f0dc9e6d78f25119217bfb704eecbabed9bba09d567556913018f69d903858a84e8150298690
diff --git a/net-irc/weechat/weechat-4.3.2.ebuild b/net-irc/weechat/weechat-4.3.2.ebuild
new file mode 100644
index 000000000000..ae190a67def6
--- /dev/null
+++ b/net-irc/weechat/weechat-4.3.2.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake lua-single python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/weechat/weechat.git"
+else
+ inherit verify-sig
+ SRC_URI="https://weechat.org/files/src/${P}.tar.xz
+ verify-sig? ( https://weechat.org/files/src/${P}.tar.xz.asc )"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/weechat.org.asc
+ BDEPEND+="verify-sig? ( sec-keys/openpgp-keys-weechat )"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Portable and multi-interface IRC client"
+HOMEPAGE="https://weechat.org/"
+
+LICENSE="GPL-3+"
+SLOT="0/${PV}"
+
+NETWORKS="+irc"
+PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spell +trigger +typing +xfer"
+# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
+# dev-lang/php eclass support is lacking, php plugins don't work. bug #705702
+SCRIPT_LANGS="guile lua +perl +python ruby tcl"
+LANGS=" cs de es fr it ja pl ru"
+IUSE="doc enchant man nls relay-api selinux test +zstd ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+
+REQUIRED_USE="
+ enchant? ( spell )
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( nls )
+ relay-api? ( relay )
+"
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls:=
+ sys-libs/ncurses:0=
+ sys-libs/zlib:=
+ net-misc/curl[ssl]
+ charset? ( virtual/libiconv )
+ guile? ( >=dev-scheme/guile-2.0:12= )
+ lua? ( ${LUA_DEPS} )
+ nls? ( virtual/libintl )
+ perl? (
+ dev-lang/perl:=
+ virtual/libcrypt:=
+ )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ || (
+ dev-lang/ruby:3.3
+ dev-lang/ruby:3.2
+ dev-lang/ruby:3.1
+ )
+ )
+ selinux? ( sec-policy/selinux-irc )
+ spell? (
+ enchant? ( app-text/enchant:* )
+ !enchant? ( app-text/aspell )
+ )
+ tcl? ( >=dev-lang/tcl-8.4.15:0= )
+ zstd? ( app-arch/zstd:= )
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-util/cpputest )
+"
+
+BDEPEND+="
+ virtual/pkgconfig
+ doc? ( >=dev-ruby/asciidoctor-1.5.4 )
+ man? ( >=dev-ruby/asciidoctor-1.5.4 )
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3-cmake_lua_version.patch
+)
+
+DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # install only required translations
+ local i
+ for i in ${LANGS} ; do
+ if ! has ${i} ${LINGUAS-${i}} ; then
+ sed -i \
+ -e "/${i}.po/d" \
+ po/CMakeLists.txt || die
+ fi
+ done
+
+ # install only required documentation ; en always
+ local j
+ for i in $(grep -e 'set(.*en.*)$' doc/CMakeLists.txt \
+ | sed -e 's/.*set(\(\w\+\).*/\1/'); do
+ for j in $(grep set.${i} doc/CMakeLists.txt \
+ | sed -e "s/.*${i}\(.*\)).*/\1/" -e 's/ en//'); do
+ if ! has ${j} ${LINGUAS-${j}} ; then
+ sed -i \
+ -e "s/\(set(${i}.*\) ${j}/\1/" \
+ doc/CMakeLists.txt || die
+ fi
+ done
+ done
+
+ # install docs in correct directory
+ sed -i "s#\${DATAROOTDIR}/doc/\${PROJECT_NAME}#\0-${PVR}/html#" doc/CMakeLists.txt || die
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ # fix linking error on Darwin
+ sed -i "s/+ get_config_var('LINKFORSHARED')//" \
+ cmake/FindPython.cmake || die
+ # allow to find the plugins by default
+ sed -i 's/".so,.dll"/".bundle,.so,.dll"/' \
+ src/core/wee-config.c || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ -DENABLE_JAVASCRIPT=OFF
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_NCURSES=ON
+ -DENABLE_PHP=OFF
+ -DENABLE_ALIAS=$(usex alias)
+ -DENABLE_BUFLIST=$(usex buflist)
+ -DENABLE_CHARSET=$(usex charset)
+ # -DENABLE_DOC requires all plugins (except javascript).
+ # https://github.com/weechat/weechat/blob/v4.0.2/CMakeLists.txt#L144
+ # Impossible since php was dropped in net-irc/weechat-3.5.r1.ebuild. bug #705702
+ -DENABLE_DOC=OFF
+ -DENABLE_DOC_INCOMPLETE=$(usex doc)
+ -DENABLE_ENCHANT=$(usex enchant)
+ -DENABLE_EXEC=$(usex exec)
+ -DENABLE_FIFO=$(usex fifo)
+ -DENABLE_FSET=$(usex fset)
+ -DENABLE_GUILE=$(usex guile)
+ -DENABLE_IRC=$(usex irc)
+ -DENABLE_LOGGER=$(usex logger)
+ -DENABLE_LUA=$(usex lua)
+ -DENABLE_MAN=$(usex man)
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_PERL=$(usex perl)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_RELAY=$(usex relay)
+ -DENABLE_CJSON=$(usex relay-api)
+ -DENABLE_RUBY=$(usex ruby)
+ -DENABLE_SCRIPT=$(usex scripts)
+ -DENABLE_SCRIPTS=$(usex scripts)
+ -DENABLE_SPELL=$(usex spell)
+ -DENABLE_TCL=$(usex tcl)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TRIGGER=$(usex trigger)
+ -DENABLE_TYPING=$(usex typing)
+ -DENABLE_XFER=$(usex xfer)
+ -DENABLE_ZSTD=$(usex zstd)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ if $(locale -a | grep -iq "en_US\.utf.*8"); then
+ cmake_src_test -V
+ else
+ eerror "en_US.UTF-8 locale is required to run ${PN}'s ${FUNCNAME}"
+ die "required locale missing"
+ fi
+}