summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-05 01:42:41 -0400
committerSam James <sam@gentoo.org>2024-04-07 07:16:12 +0100
commita442fa8f588845a7d8daa972cae1c3d936bfdbc9 (patch)
treeefa3aa133296ddc1100b0f9240c42c2f06609ca3 /net-wireless
parentnet-p2p/qbittorrent: add 4.6.4 (diff)
downloadgentoo-a442fa8f588845a7d8daa972cae1c3d936bfdbc9.tar.gz
gentoo-a442fa8f588845a7d8daa972cae1c3d936bfdbc9.tar.bz2
gentoo-a442fa8f588845a7d8daa972cae1c3d936bfdbc9.zip
net-wireless/kismet: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/877761 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet/kismet-2022.08.1-r2.ebuild12
-rw-r--r--net-wireless/kismet/kismet-2023.07.1.ebuild12
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild12
3 files changed, 30 insertions, 6 deletions
diff --git a/net-wireless/kismet/kismet-2022.08.1-r2.ebuild b/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
index 0965409505a7..fe81d7a6be92 100644
--- a/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
+++ b/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..12} )
-inherit autotools python-single-r1 udev systemd
+inherit autotools flag-o-matic python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -123,6 +123,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/877761
+ # https://github.com/kismetwireless/kismet/issues/518
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf \
$(use_enable libusb libusb) \
$(use_enable pcre) \
diff --git a/net-wireless/kismet/kismet-2023.07.1.ebuild b/net-wireless/kismet/kismet-2023.07.1.ebuild
index d811631a3fe8..004920a80551 100644
--- a/net-wireless/kismet/kismet-2023.07.1.ebuild
+++ b/net-wireless/kismet/kismet-2023.07.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..12} )
-inherit autotools python-single-r1 udev systemd
+inherit autotools flag-o-matic python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -114,6 +114,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/877761
+ # https://github.com/kismetwireless/kismet/issues/518
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf \
$(use_enable libusb libusb) \
$(use_enable libusb wifi-coconut) \
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 84a92eaf262c..4323fb204364 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..12} )
-inherit autotools python-single-r1 udev systemd
+inherit autotools flag-o-matic python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -112,6 +112,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/877761
+ # https://github.com/kismetwireless/kismet/issues/518
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf \
$(use_enable libusb libusb) \
$(use_enable libusb wifi-coconut) \