summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-calculators/tiemu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-calculators/tiemu')
-rw-r--r--sci-calculators/tiemu/Manifest1
-rw-r--r--sci-calculators/tiemu/files/tiemu-3.03-r2820.patch28
-rw-r--r--sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch232
-rw-r--r--sci-calculators/tiemu/metadata.xml12
-rw-r--r--sci-calculators/tiemu/tiemu-3.03.ebuild61
5 files changed, 334 insertions, 0 deletions
diff --git a/sci-calculators/tiemu/Manifest b/sci-calculators/tiemu/Manifest
new file mode 100644
index 000000000000..6e7251f19458
--- /dev/null
+++ b/sci-calculators/tiemu/Manifest
@@ -0,0 +1 @@
+DIST tiemu_3.03.orig.tar.gz 27343892 SHA256 c47b1c58640622c0fac9049d83eb8953d5805e54dede32cb2d3aa6453fb9ce8b SHA512 417f57b14ff603bc35ec1dcd7e6a884c28dc9decddcf775318cac1db383907a59d24dcef3c96324703a896672bd54caa51220126edd9e6c1642d87c4e75e127a WHIRLPOOL 4e09ea96d0f18d387c5bb1cb4a2f4acdb05fe401c2d1340f8891aeb590423a36a35e98b095d824be10546db772afebbff4b75ca29f86ce022db334dfeb5d32d0
diff --git a/sci-calculators/tiemu/files/tiemu-3.03-r2820.patch b/sci-calculators/tiemu/files/tiemu-3.03-r2820.patch
new file mode 100644
index 000000000000..cf563e8d4c67
--- /dev/null
+++ b/sci-calculators/tiemu/files/tiemu-3.03-r2820.patch
@@ -0,0 +1,28 @@
+Removed obsolete virtual link cable.
+
+http://svn.tilp.info/cgi-bin/viewvc.cgi?view=rev&root=tiemu&revision=2820
+https://bugs.gentoo.org/show_bug.cgi?id=363383
+
+--- src/gui/device.c
++++ src/gui/device.c
+@@ -102,10 +102,6 @@
+ gtk_option_menu_set_history(GTK_OPTION_MENU(data), 7);
+ break;
+
+- case CABLE_VTL:
+- gtk_option_menu_set_history(GTK_OPTION_MENU(data), 8);
+- break;
+-
+ case CABLE_ILP:
+ gtk_option_menu_set_history(GTK_OPTION_MENU(data), 9);
+ break;
+@@ -194,8 +190,7 @@
+ case 5: tmp.cable_model = CABLE_USB; break;
+ case 6: tmp.cable_model = CABLE_VTI; break;
+ case 7: tmp.cable_model = CABLE_TIE; break;
+- case 8: tmp.cable_model = CABLE_VTL; break;
+- case 9: tmp.cable_model = CABLE_ILP; break;
++ case 8: tmp.cable_model = CABLE_ILP; break;
+ }
+ }
+
diff --git a/sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch b/sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch
new file mode 100644
index 000000000000..10a0e1a11341
--- /dev/null
+++ b/sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch
@@ -0,0 +1,232 @@
+--- src/gui/debugger/dbg_bkpts.c
++++ src/gui/debugger/dbg_bkpts.c
+@@ -29,10 +29,15 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_regs.c
++++ src/gui/debugger/dbg_regs.c
+@@ -28,14 +28,19 @@
+ # include <config.h>
+ #endif
+
+-#include <gtk/gtk.h>
+-#include <glade/glade.h>
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <gtk/gtk.h>
++#include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_pclog.c
++++ src/gui/debugger/dbg_pclog.c
+@@ -31,6 +31,11 @@
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_wnds.c
++++ src/gui/debugger/dbg_wnds.c
+@@ -38,6 +38,11 @@
+ #include <windows.h>
+ #endif
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "ti68k_int.h"
+ #include "struct.h"
+--- src/gui/debugger/dbg_mem.c
++++ src/gui/debugger/dbg_mem.c
+@@ -33,6 +33,11 @@
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+--- src/gui/debugger/dbg_iop.c
++++ src/gui/debugger/dbg_iop.c
+@@ -28,13 +28,18 @@
+ # include <config.h>
+ #endif
+
+-#include <gtk/gtk.h>
+-#include <glade/glade.h>
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <gtk/gtk.h>
++#include <glade/glade.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_stack.c
++++ src/gui/debugger/dbg_stack.c
+@@ -28,11 +28,16 @@
+ # include <config.h>
+ #endif
+
++#include <stdlib.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+-#include <stdlib.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_all.c
++++ src/gui/debugger/dbg_all.c
+@@ -38,6 +38,13 @@
+ #include <windows.h>
+ #endif
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_SENSITIVE
++#define GTK_WIDGET_SENSITIVE(wid) (gtk_widget_get_sensitive(wid))
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "ti68k_int.h"
+ #include "struct.h"
+ #include "dbg_all.h"
+--- src/gui/debugger/dbg_code.c
++++ src/gui/debugger/dbg_code.c
+@@ -28,11 +28,16 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_SENSITIVE
++#define GTK_WIDGET_SENSITIVE(wid) (gtk_widget_get_sensitive(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_heap.c
++++ src/gui/debugger/dbg_heap.c
+@@ -31,6 +31,11 @@
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_dock.c
++++ src/gui/debugger/dbg_dock.c
+@@ -37,11 +37,16 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/calc/calc.c
++++ src/gui/calc/calc.c
+@@ -39,6 +39,11 @@
+ #include <glade/glade.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_STATE
++#define GTK_WIDGET_STATE(wid) (gtk_widget_get_state(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "skinops.h"
+--- src/gui/calc/screen.c
++++ src/gui/calc/screen.c
+@@ -29,11 +29,16 @@
+ # include <config.h>
+ #endif /* */
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_STATE
++#define GTK_WIDGET_STATE(wid) (gtk_widget_get_state(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "skinops.h"
diff --git a/sci-calculators/tiemu/metadata.xml b/sci-calculators/tiemu/metadata.xml
new file mode 100644
index 000000000000..3f72a1c51b7d
--- /dev/null
+++ b/sci-calculators/tiemu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ This project aims to develop a fast emulator for the
+ TI89(titanium), 92(+), and V200PLT calculators. This emulator
+ started on the Jonas Minnberg's (X)Tiger emulator which is
+ based on UAE (the Universal Amiga Emulator). It was deeply
+ reworked and improved thus it's very different now.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-calculators/tiemu/tiemu-3.03.ebuild b/sci-calculators/tiemu/tiemu-3.03.ebuild
new file mode 100644
index 000000000000..730bde9e19ff
--- /dev/null
+++ b/sci-calculators/tiemu/tiemu-3.03.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Texas Instruments hand-helds emulator"
+HOMEPAGE="http://lpg.ticalc.org/prj_tiemu/"
+SRC_URI="http://repo.calcforge.org/debian/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus nls sdl threads xinerama"
+
+RDEPEND="sci-libs/libticables2
+ sci-libs/libticalcs2
+ sci-libs/libtifiles2
+ sci-libs/libticonv
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ nls? ( virtual/libintl )
+ sdl? ( media-libs/libsdl )
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch \
+ "${FILESDIR}"/${P}-r2820.patch
+
+ # Don't use GTK_DISABLE_DEPRECATED flags
+ sed 's:-DGTK_DISABLE_DEPRECATED::g' -i configure.ac configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --disable-debugger \
+ --disable-gdb \
+ $(use_enable nls) \
+ $(use_enable sdl sound) \
+ $(use_enable threads) \
+ $(use_enable threads threading) \
+ $(use_with dbus) \
+ --without-kde \
+ $(use_with xinerama)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES}
+ make_desktop_entry tiemu "TiEmu Calculator" \
+ "${EPREFIX}"/usr/share/tiemu/pixmaps/icon.xpm
+}