summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-09 19:00:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-09 19:19:27 +0200
commitb978a17ecb4e1ccd62317d664e9af15fb3034f24 (patch)
treecf381f69499ddb267302feb689dc0b448fd3d42b /sci-libs/matio
parentmedia-libs/mesa: Add SLOT="amber" branch (diff)
downloadgentoo-b978a17ecb4e1ccd62317d664e9af15fb3034f24.tar.gz
gentoo-b978a17ecb4e1ccd62317d664e9af15fb3034f24.tar.bz2
gentoo-b978a17ecb4e1ccd62317d664e9af15fb3034f24.zip
sci-libs/matio: add 1.5.23
Bug: https://bugs.gentoo.org/842258 Bug: https://bugs.gentoo.org/803131 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/matio')
-rw-r--r--sci-libs/matio/Manifest1
-rw-r--r--sci-libs/matio/matio-1.5.23.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
index c201252bd95a..f2240eab33cf 100644
--- a/sci-libs/matio/Manifest
+++ b/sci-libs/matio/Manifest
@@ -1 +1,2 @@
DIST matio-1.5.21.tar.gz 10110430 BLAKE2B 1c43d44e69b28eacd9cc672a393df6a55c4ea0e06334eace9058b45bb0bd1582d43cafd30ad121bad33ad29dda52d5259be8c38f6cbacdb05a47da3644dfb984 SHA512 b00bcad807e6a7e10afa656eb77a0e3e9fb08d9cecc3e94ba41ef91ce60367d6686e6d387a874bbb83eb2f895d4a97caac554a70e7f5f6f5cb750052702d411c
+DIST matio-1.5.23.tar.gz 10115808 BLAKE2B a461cd8a0057db2bf1bc0249f4e9c3a0b901bc19fc274c7b9c38d3376b86d556bcfd997a32d5eb7d03b911f7a265c35ee337d98daccea5549d4e16d16f67932b SHA512 e125278dcb25695affb7c576d0e2a86c0eff4225aa866b81536c9e4d7b2aea2c554f5389e96d534a8b559f5554b6cbecff4b44fe8915173cd64b2da6d1dc2629
diff --git a/sci-libs/matio/matio-1.5.23.ebuild b/sci-libs/matio/matio-1.5.23.ebuild
new file mode 100644
index 000000000000..50ba1730381e
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.23.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="https://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/11" # subslot = soname version
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( virtual/latex-base )"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse)
+}
+
+src_compile() {
+ default
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc documentation/matio_user_guide.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc test/test*.c
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+
+ # no static archives
+ find "${ED}" -name "*.la" -delete || die
+}