summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-11-30 13:56:25 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-12-05 13:16:25 +0100
commit62416df0db8bdd34182c6ef5d626ba33e7b91a97 (patch)
tree836ba7779689dbf7e42de1df2475383d773756af /sci-physics
parentdev-python/ansible-pygments: enable py3.12 (diff)
downloadgentoo-62416df0db8bdd34182c6ef5d626ba33e7b91a97.tar.gz
gentoo-62416df0db8bdd34182c6ef5d626ba33e7b91a97.tar.bz2
gentoo-62416df0db8bdd34182c6ef5d626ba33e7b91a97.zip
sci-physics/root: drop USE flags for C++ standard
ROOT 6.30/00 and above no longer support C++14, and now uses the compiler default (i.e. C++17 for GCC 11 and above), so we can drop these USE flags entirely, as they create unnecessary trouble for ROOT's dependencies and other related packages. The recommended way to set the C++ standard different than the compiler default from now on should be using MYCMAKEARGS in a portage environment. Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/metadata.xml2
-rw-r--r--sci-physics/root/root-6.28.10-r1.ebuild (renamed from sci-physics/root/root-6.28.10.ebuild)12
-rw-r--r--sci-physics/root/root-6.30.02-r1.ebuild (renamed from sci-physics/root/root-6.30.02.ebuild)12
-rw-r--r--sci-physics/root/root-6.30.9999.ebuild12
-rw-r--r--sci-physics/root/root-9999.ebuild12
5 files changed, 20 insertions, 30 deletions
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index 0ce5b7e0cb6a..1d44dde0a37c 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -24,8 +24,6 @@
</upstream>
<use>
<flag name="asimage">Enable support for <pkg>media-libs/libafterimage</pkg></flag>
- <flag name="c++14">Build using the C++14 standard</flag>
- <flag name="c++17">Build using the C++17 standard</flag>
<flag name="cuda">Enable support for nVidia CUDA</flag>
<flag name="cudnn">Enable support for nVidia cuDNN library</flag>
<flag name="davix">Enable support for DAVIX Data Management Client (https://cern.ch/davix)</flag>
diff --git a/sci-physics/root/root-6.28.10.ebuild b/sci-physics/root/root-6.28.10-r1.ebuild
index 32012c31e7b4..831e28f81da0 100644
--- a/sci-physics/root/root-6.28.10.ebuild
+++ b/sci-physics/root/root-6.28.10-r1.ebuild
@@ -13,10 +13,11 @@ inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X aqua +asimage c++14 +c++17 cuda cudnn +davix debug +examples
- fits fftw fortran +gdml graphviz +gsl http jupyter libcxx +minuit mpi
- mysql odbc +opengl oracle postgres pythia6 pythia8 +python qt5 R +roofit
- +root7 shadow sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+ +gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
+ oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
+ sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+
RESTRICT="test"
PROPERTIES="test_network"
@@ -38,7 +39,6 @@ fi
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
REQUIRED_USE="
- ^^ ( c++14 c++17 )
cuda? ( tmva )
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
@@ -47,7 +47,6 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
- root7? ( || ( c++17 ) )
tmva? ( gsl python )
uring? ( root7 )
"
@@ -175,7 +174,6 @@ src_configure() {
-DCMAKE_CUDA_HOST_COMPILER="$(tc-getCXX)"
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
- -DCMAKE_CXX_STANDARD=$( (usev c++14 || usev c++17) | cut -c4-)
# set build type flags to empty to avoid overriding CXXFLAGS
-UCMAKE_C_FLAGS_RELEASE
-UCMAKE_C_FLAGS_RELWITHDEBINFO
diff --git a/sci-physics/root/root-6.30.02.ebuild b/sci-physics/root/root-6.30.02-r1.ebuild
index 32012c31e7b4..831e28f81da0 100644
--- a/sci-physics/root/root-6.30.02.ebuild
+++ b/sci-physics/root/root-6.30.02-r1.ebuild
@@ -13,10 +13,11 @@ inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X aqua +asimage c++14 +c++17 cuda cudnn +davix debug +examples
- fits fftw fortran +gdml graphviz +gsl http jupyter libcxx +minuit mpi
- mysql odbc +opengl oracle postgres pythia6 pythia8 +python qt5 R +roofit
- +root7 shadow sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+ +gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
+ oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
+ sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+
RESTRICT="test"
PROPERTIES="test_network"
@@ -38,7 +39,6 @@ fi
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
REQUIRED_USE="
- ^^ ( c++14 c++17 )
cuda? ( tmva )
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
@@ -47,7 +47,6 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
- root7? ( || ( c++17 ) )
tmva? ( gsl python )
uring? ( root7 )
"
@@ -175,7 +174,6 @@ src_configure() {
-DCMAKE_CUDA_HOST_COMPILER="$(tc-getCXX)"
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
- -DCMAKE_CXX_STANDARD=$( (usev c++14 || usev c++17) | cut -c4-)
# set build type flags to empty to avoid overriding CXXFLAGS
-UCMAKE_C_FLAGS_RELEASE
-UCMAKE_C_FLAGS_RELWITHDEBINFO
diff --git a/sci-physics/root/root-6.30.9999.ebuild b/sci-physics/root/root-6.30.9999.ebuild
index 32012c31e7b4..831e28f81da0 100644
--- a/sci-physics/root/root-6.30.9999.ebuild
+++ b/sci-physics/root/root-6.30.9999.ebuild
@@ -13,10 +13,11 @@ inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X aqua +asimage c++14 +c++17 cuda cudnn +davix debug +examples
- fits fftw fortran +gdml graphviz +gsl http jupyter libcxx +minuit mpi
- mysql odbc +opengl oracle postgres pythia6 pythia8 +python qt5 R +roofit
- +root7 shadow sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+ +gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
+ oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
+ sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+
RESTRICT="test"
PROPERTIES="test_network"
@@ -38,7 +39,6 @@ fi
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
REQUIRED_USE="
- ^^ ( c++14 c++17 )
cuda? ( tmva )
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
@@ -47,7 +47,6 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
- root7? ( || ( c++17 ) )
tmva? ( gsl python )
uring? ( root7 )
"
@@ -175,7 +174,6 @@ src_configure() {
-DCMAKE_CUDA_HOST_COMPILER="$(tc-getCXX)"
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
- -DCMAKE_CXX_STANDARD=$( (usev c++14 || usev c++17) | cut -c4-)
# set build type flags to empty to avoid overriding CXXFLAGS
-UCMAKE_C_FLAGS_RELEASE
-UCMAKE_C_FLAGS_RELWITHDEBINFO
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 32012c31e7b4..831e28f81da0 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -13,10 +13,11 @@ inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X aqua +asimage c++14 +c++17 cuda cudnn +davix debug +examples
- fits fftw fortran +gdml graphviz +gsl http jupyter libcxx +minuit mpi
- mysql odbc +opengl oracle postgres pythia6 pythia8 +python qt5 R +roofit
- +root7 shadow sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+ +gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
+ oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
+ sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
+
RESTRICT="test"
PROPERTIES="test_network"
@@ -38,7 +39,6 @@ fi
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
REQUIRED_USE="
- ^^ ( c++14 c++17 )
cuda? ( tmva )
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
@@ -47,7 +47,6 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
qt5? ( root7 )
roofit? ( minuit )
- root7? ( || ( c++17 ) )
tmva? ( gsl python )
uring? ( root7 )
"
@@ -175,7 +174,6 @@ src_configure() {
-DCMAKE_CUDA_HOST_COMPILER="$(tc-getCXX)"
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
- -DCMAKE_CXX_STANDARD=$( (usev c++14 || usev c++17) | cut -c4-)
# set build type flags to empty to avoid overriding CXXFLAGS
-UCMAKE_C_FLAGS_RELEASE
-UCMAKE_C_FLAGS_RELWITHDEBINFO