summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-15 01:25:37 +0100
committerSam James <sam@gentoo.org>2024-08-15 01:26:16 +0100
commit182d0bcc12df904e8ab40dcb902c555a1aed34e5 (patch)
tree31ecec1d4280d4b8dfa2509e8b0feb6213349388 /sys-apps
parentdev-util/fq: add 0.12.0 (diff)
downloadgentoo-182d0bcc12df904e8ab40dcb902c555a1aed34e5.tar.gz
gentoo-182d0bcc12df904e8ab40dcb902c555a1aed34e5.tar.bz2
gentoo-182d0bcc12df904e8ab40dcb902c555a1aed34e5.zip
sys-apps/kmod: workaround broken man dist logic
The man pages are in the dist but if they're not set to be *built*, the directory isn't recursed into. Workaround that in src_install. Closes: https://bugs.gentoo.org/937942 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/kmod-33.ebuild10
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild10
2 files changed, 20 insertions, 0 deletions
diff --git a/sys-apps/kmod/kmod-33.ebuild b/sys-apps/kmod/kmod-33.ebuild
index 3b1e8cdb68ca..b9af14296739 100644
--- a/sys-apps/kmod/kmod-33.ebuild
+++ b/sys-apps/kmod/kmod-33.ebuild
@@ -91,12 +91,22 @@ src_configure() {
$(use_with zstd)
)
+ if [[ ${PV} != 9999 ]] ; then
+ # See src_install
+ myeconfargs+=( --disable-manpages )
+ fi
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+ if [[ ${PV} != 9999 ]] ; then
+ # The dist logic is broken but the files are in there (bug #937942)
+ emake -C man DESTDIR="${D}" install
+ fi
+
find "${ED}" -type f -name "*.la" -delete || die
if use tools; then
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 3b1e8cdb68ca..b9af14296739 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -91,12 +91,22 @@ src_configure() {
$(use_with zstd)
)
+ if [[ ${PV} != 9999 ]] ; then
+ # See src_install
+ myeconfargs+=( --disable-manpages )
+ fi
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+ if [[ ${PV} != 9999 ]] ; then
+ # The dist logic is broken but the files are in there (bug #937942)
+ emake -C man DESTDIR="${D}" install
+ fi
+
find "${ED}" -type f -name "*.la" -delete || die
if use tools; then