summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-02-28 19:56:02 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-02-28 20:07:16 -0500
commit14fc76ae0ade2b986ca8d73a35e5383e0a81372b (patch)
treefa9d0ce9faa4736b274fb1c74b947f1b91ce78bb /sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
parentsys-devel/automake: Rev bump to remove Python 2.7 dependency for FEATURES=-test (diff)
downloadgentoo-14fc76ae0ade2b986ca8d73a35e5383e0a81372b.tar.gz
gentoo-14fc76ae0ade2b986ca8d73a35e5383e0a81372b.tar.bz2
gentoo-14fc76ae0ade2b986ca8d73a35e5383e0a81372b.zip
sys-fs/f2fs-tools: version bump to 1.10.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
new file mode 100644
index 000000000000..94561df90d65
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )"
+DEPEND="$RDEPEND"
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}