summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-05-31 12:19:54 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-09 21:54:00 +0200
commit12824750519455a17a8aa80662b105ac99195981 (patch)
tree7fdf0d1047ae254de9ea22b555d4f7d9eaf321d1 /www-client
parentdev-python/pywinrm: Unbundle requests-kerberos (diff)
downloadgentoo-12824750519455a17a8aa80662b105ac99195981.tar.gz
gentoo-12824750519455a17a8aa80662b105ac99195981.tar.bz2
gentoo-12824750519455a17a8aa80662b105ac99195981.zip
www-client/epiphany: Bump to 46.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36923 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-46.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 6c38e85afcc6..ce8de90b7275 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-46.0.tar.xz 4014980 BLAKE2B e9e72dc562b4ee63698e5b2c8f87945988cd5c585a10ee6782cd2a2fadbdb363292227869ed7f39f46305e007729594a37fc06a384a7a53e2061c2b3da181ce5 SHA512 55d1e89294e0f7cfae10b6aa28f43028bd34053e1d829168bf59b9cce8a8128a2ed7e9b94b8665e0f36e03adae845e0a26ff40c83abbc9962f06ac75e3c36a79
+DIST epiphany-46.2.tar.xz 4021080 BLAKE2B f1ed20b1bd22ab047bff04276ac915996827d64b5edd7dfee6ae816522338f614b1329b051b84064cb1448590de7a432d521146a5a94915605f3841e6fc8c5c7 SHA512 fe564b2cb1c5f3528f974826d17608f133b8b99cc3dcfad1c641bf7aef792addbcb2418b7dba5a3c56305ee5fc2c955a5a12d1e64c50a60376f638cad3766ec9
diff --git a/www-client/epiphany/epiphany-46.2.ebuild b/www-client/epiphany/epiphany-46.2.ebuild
new file mode 100644
index 000000000000..910ff618f805
--- /dev/null
+++ b/www-client/epiphany/epiphany-46.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.9.0:4=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.74.0:2
+ gnome-base/gsettings-desktop-schemas
+ media-libs/gstreamer:1.0
+ >=gui-libs/gtk-4.12.0:4
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=gui-libs/libadwaita-1.4.0:1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.43.4:6
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dgranite=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}