summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 18:40:14 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 18:40:14 +0100
commit81ce470c8ce8d8a04d089228a1bb0b7ef4df4493 (patch)
treecf3b668279baa1115800c3ddea07b9a18cb09cb9 /x11-misc/bbrun
parentx11-misc/bbppp: Port to EAPI 7 (diff)
downloadgentoo-81ce470c8ce8d8a04d089228a1bb0b7ef4df4493.tar.gz
gentoo-81ce470c8ce8d8a04d089228a1bb0b7ef4df4493.tar.bz2
gentoo-81ce470c8ce8d8a04d089228a1bb0b7ef4df4493.zip
x11-misc/bbrun: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/bbrun')
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild26
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-list.patch10
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-makefile.patch4
3 files changed, 21 insertions, 19 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
index 07fa033e05dc..f9bd99cef70b 100644
--- a/x11-misc/bbrun/bbrun-1.6-r1.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="blackbox program execution dialog box"
HOMEPAGE="http://www.darkops.net/bbrun"
@@ -12,17 +12,21 @@ SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- x11-libs/libXpm
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${P}-list.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-list.patch
+)
src_compile() {
emake -C ${PN} CC="$(tc-getCC)"
diff --git a/x11-misc/bbrun/files/bbrun-1.6-list.patch b/x11-misc/bbrun/files/bbrun-1.6-list.patch
index 654b4f68144e..d487efc3d5a7 100644
--- a/x11-misc/bbrun/files/bbrun-1.6-list.patch
+++ b/x11-misc/bbrun/files/bbrun-1.6-list.patch
@@ -1,6 +1,5 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c 2002-02-05 18:36:19.000000000 +0100
-+++ wmgeneral/list.c 2016-01-04 12:54:39.666670005 +0100
+--- a/wmgeneral/list.c
++++ b/wmgeneral/list.c
@@ -38,7 +38,7 @@
/* Return a cons cell produced from (head . tail) */
@@ -82,9 +81,8 @@ diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
list_mapcar(LinkedList* list, void(*function)(void*))
{
while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h 2002-02-05 18:36:19.000000000 +0100
-+++ wmgeneral/list.h 2016-01-04 12:54:39.666670005 +0100
+--- a/wmgeneral/list.h
++++ b/wmgeneral/list.h
@@ -29,31 +29,25 @@
#ifndef __LIST_H_
#define __LIST_H_
diff --git a/x11-misc/bbrun/files/bbrun-1.6-makefile.patch b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
index cf89b96df6f3..21e855746d09 100644
--- a/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
+++ b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
@@ -2,8 +2,8 @@ Respect {C,LD}FLAGS, fix underlinking
http://bugs.gentoo.org/367853
---- bbrun/Makefile
-+++ bbrun/Makefile
+--- a/bbrun/Makefile
++++ b/bbrun/Makefile
@@ -1,7 +1,7 @@
CC = gcc
LIBDIR = -L/usr/lib -L/usr/X11R6/lib