summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-02 13:27:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-02 13:27:41 +0200
commitee3d5cc6c012a95c2a2313ce16f8b681588c5b75 (patch)
tree1a33779d7b48d2a95f6a29360bd9ea3105ad0363 /xfce-base
parentdev-python/pycountry: Remove old (diff)
downloadgentoo-ee3d5cc6c012a95c2a2313ce16f8b681588c5b75.tar.gz
gentoo-ee3d5cc6c012a95c2a2313ce16f8b681588c5b75.tar.bz2
gentoo-ee3d5cc6c012a95c2a2313ce16f8b681588c5b75.zip
xfce-base/xfce4-power-manager: Bump to 4.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-power-manager/Manifest1
-rw-r--r--xfce-base/xfce4-power-manager/xfce4-power-manager-4.19.3.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/xfce-base/xfce4-power-manager/Manifest b/xfce-base/xfce4-power-manager/Manifest
index 72c45fecf6b7..8211f193bc72 100644
--- a/xfce-base/xfce4-power-manager/Manifest
+++ b/xfce-base/xfce4-power-manager/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-power-manager-4.18.3.tar.bz2 1244867 BLAKE2B a028f556f485f51668ab46ac246e07d9e94376aa1609d1c6a08e159df749bc8e37819ecdcfd09e6d2edbcb72441c06a310a4ce2f6ca1f109dd6e5b9da7d9072f SHA512 97f198ed78c3a13c5e64f0551d49533ac2efe0c719f4360eab94736790b225411b347a8524e8a2d7e28b14e546df6133df5273c80d8e0eb5766145782e1412fb
DIST xfce4-power-manager-4.19.2.tar.bz2 1506787 BLAKE2B f9ceaabaaad09f236bf7f391f3f84fe614aa2e95468204a64a6d96da580d4c249565486ca4a89be09ee14f8dc849d6393ab731a6ac50d24c689e99e3da6a59ac SHA512 3a1f43df4a980d72022f61252e5c5a1d65a424ecbf7d588fe87d24f364d6a748f4d5f107e6af973654d9a70557d4ccd639d1365c0ae88a6327ac16351c66be50
+DIST xfce4-power-manager-4.19.3.tar.bz2 1513388 BLAKE2B dfdad39878e9ee1181053ebbd8248bc7eb9ddccb6bb156d8d6093bcaab657549fc182db5ec766c968dd7a1534c7e3131d468a8cba0876f34b6a61ff8012a6b3e SHA512 984dfc52f4863bf9c9e05e5ae021c4146e5a2f7edff39582d676717073123937980387c1712ce4657c8a4816caf59f73d9e1fd3fa4c54e37ad46c2233f528f23
diff --git a/xfce-base/xfce4-power-manager/xfce4-power-manager-4.19.3.ebuild b/xfce-base/xfce4-power-manager/xfce4-power-manager-4.19.3.ebuild
new file mode 100644
index 000000000000..6e8bb995fadf
--- /dev/null
+++ b/xfce-base/xfce4-power-manager/xfce4-power-manager-4.19.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Power manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-power-manager/start
+ https://gitlab.xfce.org/xfce/xfce4-power-manager/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+panel-plugin policykit wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ >=dev-libs/glib-2.70.0
+ >=sys-power/upower-0.99.10
+ >=x11-libs/gtk+-3.24.0:3[wayland?,X?]
+ >=x11-libs/libnotify-0.7.0
+ >=xfce-base/xfconf-4.12:=
+ >=xfce-base/libxfce4ui-4.18.4:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.19.2:=
+ panel-plugin? ( >=xfce-base/xfce4-panel-4.14.0:= )
+ policykit? ( >=sys-auth/polkit-0.102 )
+ wayland? (
+ >=dev-libs/wayland-1.15
+ )
+ X? (
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libXrandr-1.5.0
+ >=x11-libs/libXext-1.0.0
+ x11-libs/libXtst
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+DEPEND+="
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ wayland? (
+ >=dev-libs/wayland-protocols-1.20
+ >=dev-util/wayland-scanner-1.15
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable policykit polkit)
+ $(use_enable panel-plugin xfce4panel)
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if ! has_version sys-apps/systemd && ! has_version sys-auth/elogind
+ then
+ elog "Suspend/hibernate support requires a logind provider installed"
+ elog "(sys-apps/systemd or sys-auth/elogind)"
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}