summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild')
-rw-r--r--app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild b/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild
new file mode 100644
index 000000000000..7b517ec1cad3
--- /dev/null
+++ b/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
+HOMEPAGE="http://www.slackware.com/config/packages.php"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-arch/cpio"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install # need explicit install line #397835
+ dodoc *.README*
+}