summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/uchardet/uchardet-0.0.1.ebuild')
-rw-r--r--dev-libs/uchardet/uchardet-0.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/uchardet/uchardet-0.0.1.ebuild b/dev-libs/uchardet/uchardet-0.0.1.ebuild
new file mode 100644
index 000000000000..5472c1d2f036
--- /dev/null
+++ b/dev-libs/uchardet/uchardet-0.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils
+
+DESCRIPTION="C port of Mozilla's Automatic Charset Detection algorithm"
+HOMEPAGE="https://code.google.com/p/uchardet/"
+SRC_URI="https://uchardet.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs || find "${ED}" -name '*.a' -delete
+}