summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/yajl/yajl-1.0.11-r1.ebuild')
-rw-r--r--dev-libs/yajl/yajl-1.0.11-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-1.0.11-r1.ebuild b/dev-libs/yajl/yajl-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..18c520cd462b
--- /dev/null
+++ b/dev-libs/yajl/yajl-1.0.11-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib vcs-snapshot
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-fix_tests.patch
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_test() {
+ emake test
+}