summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/distlib-0.3.8.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/distlib/distlib-0.3.8.ebuild b/dev-python/distlib/distlib-0.3.8.ebuild
index ca366516c9bd..7951433808d3 100644
--- a/dev-python/distlib/distlib-0.3.8.ebuild
+++ b/dev-python/distlib/distlib-0.3.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -34,6 +34,8 @@ src_prepare() {
local PATCHES=(
# use system pypiserver instead of bundled one
"${FILESDIR}"/distlib-0.3.2-system-pypiserver.py
+ # https://github.com/pypa/distlib/commit/1c08845b05d022692252ed45cb07e9cb9647caac
+ "${FILESDIR}"/${P}-py313.patch
)
# make sure it's not used