summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 498b121a1f1c..90f791c6db79 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.6.x86_64.rpm 58606472 BLAKE2B 53ac80902188314b3b820ec0f7fdfa42ee9fbace83655240eeec7375f5ba110fb1bb2729ca901c870c50ae915cf1cec621c9e3c0e4eae7ffdf0a87100cf8e816 SHA512 d89fbd99132e3758b67ec45492f0b1f5013779b612b793e54f9ea64040ab75951246500f0c9c0c860f411ce92781af37f2aff2588c8424b3659ee2aa0ea4f4e2
+DIST rocketchat-3.5.7.x86_64.rpm 58632660 BLAKE2B 8003d269256fc5dc6b2d06bf17bf86de96ce9b8803f2dbe767051d286761516eb125226d5ca8d29979da60c58bc5560fcaa50ce2437a904f8ac1ea6f80eb609f SHA512 a42830f7c38ae5882a03e880a2ba5dd96735cfdc8635f8cf02441feaf2de360f2904bb44306bc9349f8fbda3dfb4bfcf6ad70474d2e62a4e574af02584c5ece4
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.7.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.7.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}