summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/kmod-33.ebuild10
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild10
2 files changed, 20 insertions, 0 deletions
diff --git a/sys-apps/kmod/kmod-33.ebuild b/sys-apps/kmod/kmod-33.ebuild
index 3b1e8cdb68ca..b9af14296739 100644
--- a/sys-apps/kmod/kmod-33.ebuild
+++ b/sys-apps/kmod/kmod-33.ebuild
@@ -91,12 +91,22 @@ src_configure() {
$(use_with zstd)
)
+ if [[ ${PV} != 9999 ]] ; then
+ # See src_install
+ myeconfargs+=( --disable-manpages )
+ fi
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+ if [[ ${PV} != 9999 ]] ; then
+ # The dist logic is broken but the files are in there (bug #937942)
+ emake -C man DESTDIR="${D}" install
+ fi
+
find "${ED}" -type f -name "*.la" -delete || die
if use tools; then
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 3b1e8cdb68ca..b9af14296739 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -91,12 +91,22 @@ src_configure() {
$(use_with zstd)
)
+ if [[ ${PV} != 9999 ]] ; then
+ # See src_install
+ myeconfargs+=( --disable-manpages )
+ fi
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+ if [[ ${PV} != 9999 ]] ; then
+ # The dist logic is broken but the files are in there (bug #937942)
+ emake -C man DESTDIR="${D}" install
+ fi
+
find "${ED}" -type f -name "*.la" -delete || die
if use tools; then