summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-05 21:28:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-05 21:28:03 +0000
commit2ae688af187a33d367e72fa8215f60586bbc1049 (patch)
treee6a85beb33389f29456b7fb4186897a540dbc0ac
parentVersion bump. (diff)
downloadhistorical-2ae688af187a33d367e72fa8215f60586bbc1049.tar.gz
historical-2ae688af187a33d367e72fa8215f60586bbc1049.tar.bz2
historical-2ae688af187a33d367e72fa8215f60586bbc1049.zip
Version bump.
Package-Manager: portage-HEAD/cvs/Linux x86_64
-rw-r--r--dev-python/pyinotify/ChangeLog8
-rw-r--r--dev-python/pyinotify/Manifest4
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.0.ebuild42
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/pyinotify/ChangeLog b/dev-python/pyinotify/ChangeLog
index 5b101b5ee4ce..4cffc71838c1 100644
--- a/dev-python/pyinotify/ChangeLog
+++ b/dev-python/pyinotify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyinotify
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.26 2010/04/04 13:37:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.27 2010/06/05 21:28:03 arfrever Exp $
+
+*pyinotify-0.9.0 (05 Jun 2010)
+
+ 05 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyinotify-0.9.0.ebuild:
+ Version bump.
04 Apr 2010; Markos Chandras <hwoarang@gentoo.org> pyinotify-0.8.9.ebuild:
Stable on amd64 wrt bug #304005
diff --git a/dev-python/pyinotify/Manifest b/dev-python/pyinotify/Manifest
index 705854e1ec38..1267ffea6d3f 100644
--- a/dev-python/pyinotify/Manifest
+++ b/dev-python/pyinotify/Manifest
@@ -1,4 +1,6 @@
DIST pyinotify-0.8.9.tar.gz 692108 RMD160 993d5a030c9fb459575b4488f60c846135e6ebc2 SHA1 542131033c74ef65f933e624ef0565db4808793b SHA256 4aa589baabb663ac36b96a5f8c5eeb3e4687079148964444b0f628d8fff0d968
+DIST pyinotify-0.9.0.tar.gz 709255 RMD160 ea5e311044a621e21ab20be78ac5c5a524d18175 SHA1 ab4d59b2fd43cd7c7a9ab1621d34f2f795a8ce78 SHA256 af1f7d22067010cf29dd35fe17f8715f816f026c4ed769f7383fd419d4af9fd6
EBUILD pyinotify-0.8.9.ebuild 998 RMD160 c1721c0453697022cff0cf689fa3bca99b53e0e3 SHA1 a14c6d19c0d9066e0841330bdc2f226e6138d20b SHA256 bf40f79b28f65bc05c85489d7b8ea831e6b1b33ec37ae1d4eb8b22ce93dc82ff
-MISC ChangeLog 3267 RMD160 7496a2dc3d5dea8ffffc41ab4c2b1a8ce7d243b8 SHA1 82c88b58cb3666977bada7dd793ab771e5e1574d SHA256 776b0a7c1bffd8116f837f02827b9a4ce59755e95c68db20168ed1e930cb2c99
+EBUILD pyinotify-0.9.0.ebuild 1051 RMD160 d5f5ba1b8751ff07a47690c4155c27c56e090274 SHA1 11a078ee8e38f97d96161f6a65741bed86a69f68 SHA256 afb40a0196f2be013186b9a40ca3bf1e07fcb51b0595ec18b831c1fb2e5ace36
+MISC ChangeLog 3416 RMD160 799f9b68fc6f301077010b001eb5eb75ae1e631f SHA1 c8a318fc2000d7d037da9a4ec8191ae1c373e0b7 SHA256 cb7e1c1cd943fe08dd6f9078c17ab875dad7f8ff0984fe2c281d9b414d9d2f84
MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
diff --git a/dev-python/pyinotify/pyinotify-0.9.0.ebuild b/dev-python/pyinotify/pyinotify-0.9.0.ebuild
new file mode 100644
index 000000000000..873a15d1b439
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.0.ebuild,v 1.1 2010/06/05 21:28:03 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="http://trac.dbzteam.org/pyinotify http://pypi.python.org/pypi/pyinotify"
+SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+PYTHON_MODNAME="pyinotify.py"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ docinto html/python2
+ dohtml python2/docstrings/* || die "dohtml failed"
+ docinto html/python3
+ dohtml python3/docstrings/* || die "dohtml failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins python2/examples/* || die "doins failed"
+ fi
+}