summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2009-10-16 20:16:37 +0000
committerMike Doty <kingtaco@gentoo.org>2009-10-16 20:16:37 +0000
commitd2508f97732fdf2189c5dca2e9d68f9929225d87 (patch)
tree9aa1c20dfde3a0752273f00df599d56ae5496c3a
parentfix bashism in init script (bug #195939) (diff)
downloadhistorical-d2508f97732fdf2189c5dca2e9d68f9929225d87.tar.gz
historical-d2508f97732fdf2189c5dca2e9d68f9929225d87.tar.bz2
historical-d2508f97732fdf2189c5dca2e9d68f9929225d87.zip
initial import
Package-Manager: portage-2.1.7.1/cvs/Linux x86_64
-rw-r--r--net-misc/rwhoisd/ChangeLog10
-rw-r--r--net-misc/rwhoisd/Manifest7
-rw-r--r--net-misc/rwhoisd/files/rwhoisd18
-rw-r--r--net-misc/rwhoisd/files/rwhoisd-destdir.patch27
-rw-r--r--net-misc/rwhoisd/files/rwhoisd.conf8
-rw-r--r--net-misc/rwhoisd/metadata.xml9
-rw-r--r--net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild39
7 files changed, 118 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/ChangeLog b/net-misc/rwhoisd/ChangeLog
new file mode 100644
index 000000000000..1e27cb9db7dd
--- /dev/null
+++ b/net-misc/rwhoisd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/rwhoisd
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/ChangeLog,v 1.1 2009/10/16 20:16:36 kingtaco Exp $
+
+*rwhoisd-1.5.9.5 (16 Oct 2009)
+
+ 16 Oct 2009; Mike Doty <kingtaco@gentoo.org> +rwhoisd-1.5.9.5.ebuild,
+ +files/rwhoisd, +files/rwhoisd.conf, +files/rwhoisd-destdir.patch,
+ +metadata.xml:
+ Initial version
diff --git a/net-misc/rwhoisd/Manifest b/net-misc/rwhoisd/Manifest
new file mode 100644
index 000000000000..f03cb2031d2d
--- /dev/null
+++ b/net-misc/rwhoisd/Manifest
@@ -0,0 +1,7 @@
+AUX rwhoisd 284 RMD160 bbf349dbb721213a53567bd9b21910f256564fbf SHA1 6ce494cd8ed5ce7bec7ace3f0e6be5a29480ae57 SHA256 929f479426a03c84a51648c99af2d8622efee155995c6abb458ae9236f0b0051
+AUX rwhoisd-destdir.patch 926 RMD160 f261f065d71cfdd84425e1a8afdd3bbf9ff620e5 SHA1 c3509b1fd47556780f9f8f7187b59ff88243210a SHA256 2e427ba47e70f0000c725504a5c125c65190d71572a3e8aecfa4d8ccadeacc0a
+AUX rwhoisd.conf 220 RMD160 9475283fb3e0920a8214c911838fa3e1706700e2 SHA1 cd42864c97c36de55029b1dadf2414bd4127c7de SHA256 a7f7ae7d9ee401a05931896126fde2006b759524e3b8391f0fa2ab5641877586
+DIST rwhoisd-1.5.9.5.tar.gz 491600 RMD160 6535f061b758e66807fdd766407d5d1a66c03ea3 SHA1 795e0ea22a6f31916ca899b017dd580152d119a9 SHA256 832da8faff58070fcc8685c67375dcced3b6bb225ffbe3542dd6052add61cf92
+EBUILD rwhoisd-1.5.9.5.ebuild 984 RMD160 a1d1ebc58fdf56f18aed6402b94c44d7810116ff SHA1 7883fbd0e1e12ab50aaf805ef5329a5b6d5329ab SHA256 d2864ba4fab74f670b1e3215caf9f2aa055c5c5af93031ef8a7adfd2528b17c9
+MISC ChangeLog 415 RMD160 e0da0368fa52238c97ed2244a63a9a95a06311cd SHA1 5cca3ccddf120089a17617ac5e4bd1bd98e314b3 SHA256 456d4944ccfd2268b2b4f3335e789faacdd09d38e5016028bc56b2c5a414f9f7
+MISC metadata.xml 283 RMD160 5b37243e9ba52f859c1b31d198c929b11a862f7d SHA1 457a178d9d96ccce593680bb5faf8b7a38d480d5 SHA256 d9bbde44601d42c57242e05c10f67939993de79a3e88639f92cc63866da84f17
diff --git a/net-misc/rwhoisd/files/rwhoisd b/net-misc/rwhoisd/files/rwhoisd
new file mode 100644
index 000000000000..9c3b6bd05222
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+depend() {
+ use logger
+ need net
+}
+
+start() {
+ ebegin "Starting rwhoisd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/rwhoisd ${RWHOISD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tftpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rwhoisd
+ eend $?
+}
diff --git a/net-misc/rwhoisd/files/rwhoisd-destdir.patch b/net-misc/rwhoisd/files/rwhoisd-destdir.patch
new file mode 100644
index 000000000000..54369048de35
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd-destdir.patch
@@ -0,0 +1,27 @@
+--- tools/rwhois_repack/Makefile.in.orig 2009-10-16 11:30:40.000000000 -0700
++++ tools/rwhois_repack/Makefile.in 2009-10-16 11:31:20.000000000 -0700
+@@ -52,9 +52,9 @@
+ # procedural
+
+ install:
+- if [ ! -d $(exec_prefix) ]; then mkdir $(exec_prefix); fi
+- if [ ! -d $(bindir) ]; then mkdir $(bindir); fi
+- $(INSTALL) rwhois_repack $(bindir)
++ if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir $(DESTDIR)$(exec_prefix); fi
++ if [ ! -d $(DESTDIR)$(bindir) ]; then mkdir $(DESTDIR)$(bindir); fi
++ $(INSTALL) rwhois_repack $(DESTDIR)$(bindir)
+
+ uninstall:
+ $(RM) $(bindir)/rwhois_repack
+
+--- sample.data/Makefile.in.orig 2009-10-16 11:37:54.000000000 -0700
++++ sample.data/Makefile.in 2009-10-16 11:38:22.000000000 -0700
+@@ -10,7 +10,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)/bin
+-etcdir = $(exec_prefix)/etc
++etcdir = /etc
+
+ srcdir = @srcdir@
+ VPATH = @srcdir@
diff --git a/net-misc/rwhoisd/files/rwhoisd.conf b/net-misc/rwhoisd/files/rwhoisd.conf
new file mode 100644
index 000000000000..4715be3d632f
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd.conf
@@ -0,0 +1,8 @@
+#$Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/files/rwhoisd.conf,v 1.1 2009/10/16 20:16:37 kingtaco Exp $
+OPTS="-c /etc/rwhoisd/rwhoisd.conf"
+
+#Pass any additional options to rwhoisd here.
+
+RWHOISD_OPTS="${OPTS}"
+
+
diff --git a/net-misc/rwhoisd/metadata.xml b/net-misc/rwhoisd/metadata.xml
new file mode 100644
index 000000000000..9786e28c7db3
--- /dev/null
+++ b/net-misc/rwhoisd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>kingtaco@gentoo.org</email>
+</maintainer>
+<longdescription>rwhois server from ARIN</longdescription>
+</pkgmetadata>
diff --git a/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild b/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild
new file mode 100644
index 000000000000..9d2e0cc740f5
--- /dev/null
+++ b/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/rwhoisd-1.5.9.5.ebuild,v 1.1 2009/10/16 20:16:36 kingtaco Exp $
+
+EAPI=0
+inherit eutils
+
+DESCRIPTION="ARIN rwhois daemon"
+HOMEPAGE="http://projects.arin.net/rwhois/"
+SRC_URI="http://projects.arin.net/rwhois/ftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}"/rwhoisd-destdir.patch || die "epatch failed"
+ econf
+ emake -j1
+}
+
+src_install () {
+ emake -j1 install DESTDIR="${D}"
+ doinitd "${FILESDIR}"/rwhoisd || die "doinitd failed"
+ newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd || die "newconfd failed"
+}
+
+pkg_setup() {
+ enewgroup rwhoisd
+ enewuser rwhoisd -1 -1 /var/empty rwhoisd
+}
+
+pkg_postinst () {
+ einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
+ einfo "It is highly inadvisable to run rwhoisd as root."
+}