summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-20 09:50:45 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-20 09:50:45 +0000
commite3763a682f25867b4947723b73e1e7cb0dc99b21 (patch)
tree33d4017bd479b297349759893f8911663a5a8183
parentremoved ~ (diff)
downloadhistorical-e3763a682f25867b4947723b73e1e7cb0dc99b21.tar.gz
historical-e3763a682f25867b4947723b73e1e7cb0dc99b21.tar.bz2
historical-e3763a682f25867b4947723b73e1e7cb0dc99b21.zip
Version bump
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r142
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r152
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r162
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r14.ebuild63
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r15.ebuild63
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r16.ebuild63
6 files changed, 195 insertions, 0 deletions
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r14 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r14
new file mode 100644
index 000000000000..3c664a7d27f9
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r14
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 4f722250eb788a17d70732384ea85739 uml-patch-2.4.19-14.bz2 146629
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r15 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r15
new file mode 100644
index 000000000000..d21d2d7d842b
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r15
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 a05f0ec552fc18bcf3a633f305c12da2 uml-patch-2.4.19-15.bz2 149941
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r16 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r16
new file mode 100644
index 000000000000..eca459e69980
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r16
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 4dd754aea0ddd93f33194b66f4baedd0 uml-patch-2.4.19-16.bz2 150926
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r14.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r14.ebuild
new file mode 100644
index 000000000000..5b34076c37bf
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r14.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r14.ebuild,v 1.1 2002/10/20 09:50:45 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r15.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r15.ebuild
new file mode 100644
index 000000000000..0f2bbc0a0cc6
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r15.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r15.ebuild,v 1.1 2002/10/20 09:50:45 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r16.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r16.ebuild
new file mode 100644
index 000000000000..562051d9b9f8
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r16.ebuild,v 1.1 2002/10/20 09:50:45 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+