summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-02-12 17:48:34 +0000
committerJeroen Roovers <jer@gentoo.org>2011-02-12 17:48:34 +0000
commit6e696294135ee661a4cbf74560afda63385eeb13 (patch)
tree57a2c1b3ec9f4dc53c254935fad8702bd42c80ee /app-admin/checkrestart
parents390/sh stable wrt #344827 (diff)
downloadhistorical-6e696294135ee661a4cbf74560afda63385eeb13.tar.gz
historical-6e696294135ee661a4cbf74560afda63385eeb13.tar.bz2
historical-6e696294135ee661a4cbf74560afda63385eeb13.zip
Apply python 2.7 patch by Matthias Liebig for bug #352219 by Andrew Savchenko.
Package-Manager: portage-2.2.0_alpha23/cvs/Linux i686
Diffstat (limited to 'app-admin/checkrestart')
-rw-r--r--app-admin/checkrestart/ChangeLog11
-rw-r--r--app-admin/checkrestart/checkrestart-0.47-r1.ebuild30
-rw-r--r--app-admin/checkrestart/files/checkrestart-0.47-list-comprehension-fix.patch11
3 files changed, 50 insertions, 2 deletions
diff --git a/app-admin/checkrestart/ChangeLog b/app-admin/checkrestart/ChangeLog
index d27ab232bc73..ebd2d685a55e 100644
--- a/app-admin/checkrestart/ChangeLog
+++ b/app-admin/checkrestart/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/checkrestart
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/checkrestart/ChangeLog,v 1.2 2009/12/03 11:44:14 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/checkrestart/ChangeLog,v 1.3 2011/02/12 17:48:33 jer Exp $
+
+*checkrestart-0.47-r1 (12 Feb 2011)
+
+ 12 Feb 2011; Jeroen Roovers <jer@gentoo.org> +checkrestart-0.47-r1.ebuild,
+ +files/checkrestart-0.47-list-comprehension-fix.patch:
+ Apply python 2.7 patch by Matthias Liebig for bug #352219 by Andrew
+ Savchenko.
03 Dec 2009; Markus Meier <maekke@gentoo.org> checkrestart-0.47.ebuild:
add ~amd64, bug #285959
diff --git a/app-admin/checkrestart/checkrestart-0.47-r1.ebuild b/app-admin/checkrestart/checkrestart-0.47-r1.ebuild
new file mode 100644
index 000000000000..e2c398e1fa97
--- /dev/null
+++ b/app-admin/checkrestart/checkrestart-0.47-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/checkrestart/checkrestart-0.47-r1.ebuild,v 1.1 2011/02/12 17:48:33 jer Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="the sysadmin's rolling upgrade tool"
+HOMEPAGE="http://arcdraco.net/checkrestart"
+SRC_URI="http://arcdraco.net/~dragon/${P}-sep.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND="
+ sys-apps/lsb-release
+ app-portage/portage-utils
+ sys-process/lsof
+ "
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-list-comprehension-fix.patch
+}
+
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+}
diff --git a/app-admin/checkrestart/files/checkrestart-0.47-list-comprehension-fix.patch b/app-admin/checkrestart/files/checkrestart-0.47-list-comprehension-fix.patch
new file mode 100644
index 000000000000..f22f0b9e50c8
--- /dev/null
+++ b/app-admin/checkrestart/files/checkrestart-0.47-list-comprehension-fix.patch
@@ -0,0 +1,11 @@
+--- a/checkrestart
++++ b/checkrestart
+@@ -216,7 +216,7 @@
+ package.initscripts.append(path)
+
+ # Remove duplicate inits
+- package.initscripts = [ u for u in package.initscripts if u not in locals()['_[1]'] ]
++ package.initscripts = list(set(package.initscripts))
+
+ restartable = []
+ nonrestartable = []