summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-25 23:34:57 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-25 23:34:57 +0000
commit5e9929f5db115b8885985e7dac480a655960abc0 (patch)
tree238622b43cb14b69d984b6c35c8651b7eba8bb8e /app-admin/prelude-lml
parentold (diff)
downloadhistorical-5e9929f5db115b8885985e7dac480a655960abc0.tar.gz
historical-5e9929f5db115b8885985e7dac480a655960abc0.tar.bz2
historical-5e9929f5db115b8885985e7dac480a655960abc0.zip
remove old WANT_AUTOCONF
Diffstat (limited to 'app-admin/prelude-lml')
-rw-r--r--app-admin/prelude-lml/prelude-lml-0.8.6.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-admin/prelude-lml/prelude-lml-0.8.6.ebuild b/app-admin/prelude-lml/prelude-lml-0.8.6.ebuild
index 7066adddb4e3..63a637083f85 100644
--- a/app-admin/prelude-lml/prelude-lml-0.8.6.ebuild
+++ b/app-admin/prelude-lml/prelude-lml-0.8.6.ebuild
@@ -1,14 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/prelude-lml/prelude-lml-0.8.6.ebuild,v 1.2 2003/12/20 16:55:24 mboman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/prelude-lml/prelude-lml-0.8.6.ebuild,v 1.3 2004/01/25 23:31:15 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="Prelude-IDS Log Monitoring Lackey"
-HOMEPAGE="http://www.prelude-ids.org"
+HOMEPAGE="http://www.prelude-ids.org/"
SRC_URI="http://www.prelude-ids.org/download/releases/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE="doc debug"
+
DEPEND="virtual/glibc
!dev-libs/libprelude-cvs
!app-admin/prelude-lml-cvs
@@ -16,14 +20,13 @@ DEPEND="virtual/glibc
dev-libs/libpcre
doc? ( dev-util/gtk-doc )"
-RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P}
-
src_compile() {
local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --enable-gtk-doc=no"
- use debug && CFLAGS="$CFLAGS -O0 -ggdb"
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --enable-gtk-doc=no"
+ use debug && append-flags -O -ggdb
econf ${myconf} || die "econf failed"
emake || die "emake failed"