summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-09-16 16:57:23 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-09-16 16:57:23 +0000
commit11c18d698fd5e1fcc2825de256809ffaa141d68b (patch)
treec07072190fb720ffcb3ea107f0cfe20818275235 /app-antivirus
parentMarked ppc stable for bug #101333. (diff)
downloadhistorical-11c18d698fd5e1fcc2825de256809ffaa141d68b.tar.gz
historical-11c18d698fd5e1fcc2825de256809ffaa141d68b.tar.bz2
historical-11c18d698fd5e1fcc2825de256809ffaa141d68b.zip
Version bump.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/Manifest18
-rw-r--r--app-antivirus/clamav/clamav-0.87.ebuild117
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.871
4 files changed, 139 insertions, 4 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 8b5302089e97..8941981a7305 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.105 2005/09/16 12:53:30 lcars Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.106 2005/09/16 16:57:23 ticho Exp $
+
+*clamav-0.87 (16 Sep 2005)
+
+ 16 Sep 2005; Andrej Kacian <ticho@gentoo.org> +clamav-0.87.ebuild:
+ Version bump.
16 Sep 2005; Andrea Barisani <lcars@gentoo.org> clamav-0.86.2.ebuild:
Added timeout to MILTER_OPTS, bug #100980.
diff --git a/app-antivirus/clamav/Manifest b/app-antivirus/clamav/Manifest
index 3bee4cf3f583..a990fb3c2c1e 100644
--- a/app-antivirus/clamav/Manifest
+++ b/app-antivirus/clamav/Manifest
@@ -1,8 +1,20 @@
-MD5 2f721f7e2ef385a88780d7508ec3f91e ChangeLog 19311
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 0234151a2269d138109a9881280281ef clamav-0.87.ebuild 3694
MD5 0a6b99afacc591544e87d3e8bf8d7c93 clamav-0.86.2.ebuild 3689
+MD5 a5f11ef8eddba35e541b7e3d3eed2934 ChangeLog 19425
MD5 7e32edfd72887a57b16ecd73f0f7a1a0 metadata.xml 184
MD5 08f7b320461c04bbb88555e389c2e544 files/clamav-milter.README.gentoo 1124
+MD5 8365b1166d97452566de3f0f5140ab43 files/digest-clamav-0.86.2 66
+MD5 17e487f0452933ea8ab559a404329cf2 files/digest-clamav-0.87 64
+MD5 f6bf5b894e60e8686cb5a36ba240e1ef files/clamd.rc.new 2032
MD5 e29ee77ca9bfe28ed18dbf67a9c90e75 files/clamd.conf 193
MD5 1b3268d3723e003ad99bf706e6bf4312 files/clamd.rc 1444
-MD5 f6bf5b894e60e8686cb5a36ba240e1ef files/clamd.rc.new 2032
-MD5 8365b1166d97452566de3f0f5140ab43 files/digest-clamav-0.86.2 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDKvmPQlM6RnzZP+IRAqOPAJ9gryjWnfpcisuXwa6umw0ggAijUwCgu7o7
+z01l8bYHHyWvbqdonMZcWGU=
+=Us6U
+-----END PGP SIGNATURE-----
diff --git a/app-antivirus/clamav/clamav-0.87.ebuild b/app-antivirus/clamav/clamav-0.87.ebuild
new file mode 100644
index 000000000000..92c6192a0ac6
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.87.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.87.ebuild,v 1.1 2005/09/16 16:57:23 ticho Exp $
+
+inherit eutils flag-o-matic fixheadtails
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt milter selinux mailwrapper"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( mail-mta/sendmail )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ net-dns/libidn
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/lib/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newconfd ${FILESDIR}/clamd.conf clamd
+ newinitd ${FILESDIR}/clamd.rc.new clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/freshclam.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/freshclam.conf
+
+ if use milter ; then
+ echo "START_MILTER=no" \
+ >> ${D}/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>${D}/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>${D}/etc/conf.d/clamd
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "As of 0.85-r1, all settings from /etc/conf.d/clamd are ignored, except for"
+ ewarn "START_CLAMD, START_FRESHCLAM and MILTER related options. All settings are"
+ ewarn "read from /etc/clamd.conf and /etc/freshclam.conf, so double-check these two files."
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions how to setup the clamav-milter type:"
+ echo " zless /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.87 b/app-antivirus/clamav/files/digest-clamav-0.87
new file mode 100644
index 000000000000..9485c4f8a23a
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.87
@@ -0,0 +1 @@
+MD5 dd0a12deb4f48f760fa1fcd378ae7c24 clamav-0.87.tar.gz 4273714