summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-14 18:42:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-14 18:42:17 +0000
commit0a927ddadf2319cfd0cd95388a32047ca0309e69 (patch)
treef529a9de4123e20bae3253a5f6b26dc5b0a3b4bf /app-arch
parentStable x86. (diff)
downloadhistorical-0a927ddadf2319cfd0cd95388a32047ca0309e69.tar.gz
historical-0a927ddadf2319cfd0cd95388a32047ca0309e69.tar.bz2
historical-0a927ddadf2319cfd0cd95388a32047ca0309e69.zip
rename patch
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/tar/ChangeLog7
-rw-r--r--app-arch/tar/files/tar-1.15.92-stderr.patch46
2 files changed, 49 insertions, 4 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index 21f371afa28a..17aa2073b891 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,13 +1,12 @@
# ChangeLog for app-arch/tar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.67 2006/10/14 18:12:39 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.68 2006/10/14 18:42:17 vapier Exp $
*tar-1.15.92-r1 (14 Oct 2006)
14 Oct 2006; Sven Wegener <swegener@gentoo.org>
- +files/1.15.92-stderr.patch, -tar-1.15.92.ebuild, +tar-1.15.92-r1.ebuild:
- Revision bump, with patch to fix the stdin/stderr weirdness. Should fix bug
- #151239.
+ +files/tar-1.15.92-stderr.patch, +tar-1.15.92-r1.ebuild:
+ Fix from upstream for stdout/verbose bug #151239.
*tar-1.15.92 (13 Oct 2006)
diff --git a/app-arch/tar/files/tar-1.15.92-stderr.patch b/app-arch/tar/files/tar-1.15.92-stderr.patch
new file mode 100644
index 000000000000..e6dc7c6c0e24
--- /dev/null
+++ b/app-arch/tar/files/tar-1.15.92-stderr.patch
@@ -0,0 +1,46 @@
+http://bugs.gentoo.org/151239
+http://lists.gnu.org/archive/html/bug-tar/2006-10/msg00018.html
+
+2006-10-14 Sergey Poznyakoff <gray@gnu.org.ua>
+
+ * src/buffer.c (_open_archive): Make sure stdlis is set to stderr
+ when we are writing archive to stdout (unless --index-file is
+ used). Bug introduced on 2006-07-06.
+
+Index: src/buffer.c
+===================================================================
+RCS file: /sources/tar/tar/src/buffer.c,v
+retrieving revision 1.107
+retrieving revision 1.108
+diff --unified -B -b -r1.107 -r1.108
+--- src/buffer.c 2 Oct 2006 15:44:09 -0000 1.107
++++ src/buffer.c 14 Oct 2006 10:45:44 -0000 1.108
+@@ -474,6 +474,11 @@
+ abort (); /* Should not happen */
+ break;
+ }
++
++ if (!index_file_name
++ && wanted_access == ACCESS_WRITE
++ && strcmp (archive_name_array[0], "-") == 0)
++ stdlis = stderr;
+ }
+ else if (strcmp (archive_name_array[0], "-") == 0)
+ {
+@@ -499,12 +504,16 @@
+
+ case ACCESS_WRITE:
+ archive = STDOUT_FILENO;
++ if (!index_file_name)
++ stdlis = stderr;
+ break;
+
+ case ACCESS_UPDATE:
+ archive = STDIN_FILENO;
+ write_archive_to_stdout = true;
+ record_end = record_start; /* set up for 1st record = # 0 */
++ if (!index_file_name)
++ stdlis = stderr;
+ break;
+ }
+ }