summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2002-11-06 03:44:13 +0000
committerJohn P. Davis <zhen@gentoo.org>2002-11-06 03:44:13 +0000
commit10394e40f6e8b18350d6a23cf100d91bac8762ec (patch)
tree3960aed08d56552778485876b5ec6244bf68540f /app-doc
parentnew ebuild (diff)
downloadhistorical-10394e40f6e8b18350d6a23cf100d91bac8762ec.tar.gz
historical-10394e40f6e8b18350d6a23cf100d91bac8762ec.tar.bz2
historical-10394e40f6e8b18350d6a23cf100d91bac8762ec.zip
changed code to make printable text docs in doc/txt
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gentoo-web/gentoo-web-2.4.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-doc/gentoo-web/gentoo-web-2.4.ebuild b/app-doc/gentoo-web/gentoo-web-2.4.ebuild
index ae5bb1f60215..5aad771578e5 100644
--- a/app-doc/gentoo-web/gentoo-web-2.4.ebuild
+++ b/app-doc/gentoo-web/gentoo-web-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/gentoo-web/gentoo-web-2.4.ebuild,v 1.9 2002/11/01 09:53:16 peitolm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gentoo-web/gentoo-web-2.4.ebuild,v 1.10 2002/11/06 03:44:13 zhen Exp $
S=${WORKDIR}/gentoo-src/gentoo-web
TEMPLATE=${S}/xsl/guide-main.xsl
@@ -43,7 +43,8 @@ src_unpack() {
WEBROOT=${WEBROOT}
else
# give it a nice default
- WEBROOT=/home/httpd/htdocs
+ WEBROOT=/home/httpd/htdocs/gentoo/mirror
+ GENTOO_SRCDIR=/data/gentoo-src
fi
fi
@@ -64,6 +65,7 @@ src_unpack() {
src_install() {
export WEBROOT="`cat ${T}/webroot`"
dodir ${WEBROOT}/doc
+ dodir ${WEBROOT}/doc/txt
dodir ${WEBROOT}/projects
insinto ${WEBROOT}/doc
@@ -78,6 +80,14 @@ src_install() {
xsltproc $TEMPLATE ${x}.xml > ${D}${WEBROOT}/doc/${x}.html || die
done
done
+
+ local z
+ cd ${D}${WEBROOT}/doc
+ for z in *.html
+ do
+ z=`basename ${z} .html`
+ lynx -dump ${z}.html &> ${D}${WEBROOT}/doc/txt/${z}.txt || die
+ done
cd ${S}
cp txt/firewall ${D}${WEBROOT}/doc/