summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2003-10-20 07:42:00 +0000
committerSteve Arnold <nerdboy@gentoo.org>2003-10-20 07:42:00 +0000
commit83f2ac541df897afee10e5a6b523e72664cb6eba (patch)
treebdb8c10c9d62b109408a11b483348467c881eab3 /app-doc
parentversion bump and herd joinage (diff)
downloadhistorical-83f2ac541df897afee10e5a6b523e72664cb6eba.tar.gz
historical-83f2ac541df897afee10e5a6b523e72664cb6eba.tar.bz2
historical-83f2ac541df897afee10e5a6b523e72664cb6eba.zip
version bump and herd joinage
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/Manifest4
-rw-r--r--app-doc/doxygen/doxygen-1.3.4.ebuild70
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.3.41
-rw-r--r--app-doc/doxygen/metadata.xml11
4 files changed, 84 insertions, 2 deletions
diff --git a/app-doc/doxygen/Manifest b/app-doc/doxygen/Manifest
index e2107838f0af..700c690e071c 100644
--- a/app-doc/doxygen/Manifest
+++ b/app-doc/doxygen/Manifest
@@ -1,11 +1,11 @@
-MD5 c2d6860bf047a1bfaf6d09a670297d81 ChangeLog 4067
+MD5 1c07c7777f9767d549bd05ba16be76da ChangeLog 4234
MD5 badb4dd89472a82890f3ddf12494e89d doxygen-1.2.15-r1.ebuild 937
MD5 d9a549380d8a747dcc0899a12cc2ec71 doxygen-1.2.16.ebuild 939
MD5 7ee185dd64b07fc153fb636accf19871 doxygen-1.2.18.ebuild 1210
MD5 66541a19a06f6da7bf47fb4b6d4e18e2 doxygen-1.3.2.ebuild 2150
MD5 8ed60a6fb390940f07f9ddf4f2684968 doxygen-1.3.3.ebuild 2152
MD5 c102bc8284b7316928f6e80dfccd7b86 doxygen-1.3.ebuild 2143
-MD5 003c9a26a37d23560d7dbd942d99bfe8 doxygen-1.3.4.ebuild 2053
+MD5 e9dbea1e8aa3b25cf321de440af177d3 doxygen-1.3.4.ebuild 2153
MD5 c871feb91c267a09f6616d3a30b4d6ae metadata.xml 423
MD5 92e72d97f936f9a548b20e2e20e3e385 files/digest-doxygen-1.2.15-r1 71
MD5 5e330a062f712a4ec1212fdac4eb2ec4 files/digest-doxygen-1.2.16 71
diff --git a/app-doc/doxygen/doxygen-1.3.4.ebuild b/app-doc/doxygen/doxygen-1.3.4.ebuild
new file mode 100644
index 000000000000..1bbc8e8cd80b
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.3.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.3.4.ebuild,v 1.1 2003/10/20 07:41:57 nerdboy Exp $
+
+IUSE="doc qt"
+
+DESCRIPTION="Doxygen is a documentation system for C++, C, Java, IDL (Corba, Microsoft, and KDE-DCOP flavors) and to some extent PHP and C#."
+HOMEPAGE="http://www.doxygen.org"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+RDEPEND="media-gfx/graphviz
+ qt? ( x11-libs/qt )
+ doc? ( app-text/tetex
+ app-text/ghostscript )"
+
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use CFLAGS and CXXFLAGS
+ sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
+ -e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
+ tmake/lib/linux-g++/tmake.conf
+ # fix doxygen_manual.tex to work with latex-2.x
+ sed -i.orig "s:^\\\setlength\({\\\footrulewidth}\):\\\renewcommand\1:" \
+ doc/doxygen_manual.tex
+ # fix configure to work w/ install from either fileutils or coreutils
+ sed -ie "s/grep fileutils/egrep 'fileutils|coreutils'/" ${S}/configure
+}
+
+src_compile() {
+ # set ./configure options (prefix, Qt based wizard, static)
+ local confopts="--prefix ${D}/usr"
+ use qt && confopts="${confopts} --with-doxywizard"
+ #use static && confopts="${confopts} --static"
+
+ # ./configure and compile
+ ./configure ${confopts} || die '"./configure" failed.'
+ emake all || die '"emake all" failed.'
+
+ # generate html and pdf documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make docs" failed.'
+ fi
+}
+
+src_install() {
+ make install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins latex/doxygen_manual.pdf
+ dohtml -r html/*
+ fi
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.3.4 b/app-doc/doxygen/files/digest-doxygen-1.3.4
new file mode 100644
index 000000000000..d5c74ea84df7
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.3.4
@@ -0,0 +1 @@
+MD5 cd81c0f8a8e77dc33cc754f6f8852ca4 doxygen-1.3.4.src.tar.gz 2345641
diff --git a/app-doc/doxygen/metadata.xml b/app-doc/doxygen/metadata.xml
new file mode 100644
index 000000000000..ff46d5b09d17
--- /dev/null
+++ b/app-doc/doxygen/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-tools</herd>
+<maintainer>
+ <email>phosphan@gentoo.org</email>
+ <name>Patrick Kursawe</name>
+ <description>Primary Maintainer</description>
+</maintainer>
+<longdescription>Doxygen is a tool for analyzing, documenting, and reverse-engineering source code.</longdescription>
+</pkgmetadata>