summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-02-15 06:20:17 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-02-15 06:20:17 +0000
commit82e8de73d0382f7d8ebfabdcf0f6ba136b565859 (patch)
treeca7f916b972bb97f441cbf14d4ab60e9e1625540 /app-editors/hexedit
parentclarification (diff)
downloadhistorical-82e8de73d0382f7d8ebfabdcf0f6ba136b565859.tar.gz
historical-82e8de73d0382f7d8ebfabdcf0f6ba136b565859.tar.bz2
historical-82e8de73d0382f7d8ebfabdcf0f6ba136b565859.zip
Closes bug 694.
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/ChangeLog9
-rw-r--r--app-editors/hexedit/files/digest-hexedit-1.2.21
-rw-r--r--app-editors/hexedit/hexedit-1.2.2.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/hexedit/ChangeLog b/app-editors/hexedit/ChangeLog
new file mode 100644
index 000000000000..3c0205dd12f3
--- /dev/null
+++ b/app-editors/hexedit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-editors/hexedit
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/ChangeLog,v 1.1 2002/02/15 06:20:17 agenkin Exp $
+
+*hexedit-1.2.2; (14 Feb 2002)
+
+ 14 Feb 2002; Arcady Genkin <agenkin@thpoon.com> hexedit-1.2.2.ebuild :
+
+ First version of the package, submitted by Marc Soda. \ No newline at end of file
diff --git a/app-editors/hexedit/files/digest-hexedit-1.2.2 b/app-editors/hexedit/files/digest-hexedit-1.2.2
new file mode 100644
index 000000000000..248cc1a5aef9
--- /dev/null
+++ b/app-editors/hexedit/files/digest-hexedit-1.2.2
@@ -0,0 +1 @@
+MD5 99fcf36bf539a34e47c496b667b1f795 hexedit-1.2.2.src.tgz 56247
diff --git a/app-editors/hexedit/hexedit-1.2.2.ebuild b/app-editors/hexedit/hexedit-1.2.2.ebuild
new file mode 100644
index 000000000000..37931c6513f2
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Marc Soda <marc@aspre.net>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.2.ebuild,v 1.1 2002/02/15 06:20:17 agenkin Exp $
+
+S="${WORKDIR}/hexedit"
+DESCRIPTION="View and edit files in hex or ASCII."
+SRC_URI="http://merd.net/pixel/${P}.src.tgz"
+HOMEPAGE="http://www.chez.com/prigaux/hexedit.html"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses"
+
+src_compile() {
+ cd "${S}"
+ ./configure --host="${CHOST}" --prefix=/usr --mandir=/usr/share/man \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ dobin hexedit
+ doman hexedit.1
+ dodoc COPYING Changes TODO
+}