summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-05-01 17:43:12 +0000
committerAron Griffis <agriffis@gentoo.org>2004-05-01 17:43:12 +0000
commit335ae4b963d8599c4cb1b5e2a8903ba392a07580 (patch)
tree291242792d9eb470f78cf0bb5db1666c8b758aef /app-editors
parentInadvertently committed with stable ppc64 keyword, change to ~ppc64 (diff)
downloadhistorical-335ae4b963d8599c4cb1b5e2a8903ba392a07580.tar.gz
historical-335ae4b963d8599c4cb1b5e2a8903ba392a07580.tar.bz2
historical-335ae4b963d8599c4cb1b5e2a8903ba392a07580.zip
Includes patches up to 517 and selinux support, plus update to 20040430 runtime snapshot
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/ChangeLog8
-rw-r--r--app-editors/vim-core/files/digest-vim-core-6.2-r95
-rw-r--r--app-editors/vim-core/vim-core-6.2-r9.ebuild22
3 files changed, 34 insertions, 1 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index af76d02ee0e1..2202252f13f9 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.67 2004/04/20 02:17:22 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.68 2004/05/01 17:43:12 agriffis Exp $
+
+*vim-core-6.2-r9 (01 May 2004)
+
+ 01 May 2004; Aron Griffis <agriffis@gentoo.org> +vim-core-6.2-r9.ebuild:
+ Includes patches up to 517 and selinux support, plus update to 20040430
+ runtime snapshot
19 Apr 2004; Tom Gall <tgall@gentoo.org> vim-core-6.2-r8.ebuild:
added ppc64, marked stable, it works
diff --git a/app-editors/vim-core/files/digest-vim-core-6.2-r9 b/app-editors/vim-core/files/digest-vim-core-6.2-r9
new file mode 100644
index 000000000000..eee53e7a1413
--- /dev/null
+++ b/app-editors/vim-core/files/digest-vim-core-6.2-r9
@@ -0,0 +1,5 @@
+MD5 c49d360bbd069d00e2a57804f2a123d9 vim-6.2.tar.bz2 3269791
+MD5 aa0079938f636d08be71078933477d8b vim-6.2-lang.tar.gz 1093788
+MD5 7d14e62f7f3f78a043c21c04d34d9b70 vim-6.2.070-gentoo-patches.tar.bz2 4416
+MD5 e62f0b4f89b2a97afdbf731f450e46dd vim-6.2.517-patches.tar.bz2 620785
+MD5 76339650c66cee099e5e0b0e8cda62db vim-runtime-20040430.tar.bz2 2163014
diff --git a/app-editors/vim-core/vim-core-6.2-r9.ebuild b/app-editors/vim-core/vim-core-6.2-r9.ebuild
new file mode 100644
index 000000000000..450937b78129
--- /dev/null
+++ b/app-editors/vim-core/vim-core-6.2-r9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.2-r9.ebuild,v 1.1 2004/05/01 17:43:12 agriffis Exp $
+
+inherit vim
+
+VIM_VERSION="6.2"
+VIM_ORG_PATCHES="vim-6.2.517-patches.tar.bz2"
+VIM_RUNTIME_SNAP="vim-runtime-20040430.tar.bz2"
+VIM_GENTOO_PATCHES="vim-6.2.070-gentoo-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}
+ mirror://gentoo/${VIM_RUNTIME_SNAP}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~alpha ~hppa ~mips ~ppc ~sparc ~x86 ~amd64 ~ia64 ~s390 ~ppc64"
+DEPEND="${DEPEND}" # all the deps for vim-core are in vim.eclass