summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-01-22 19:43:57 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-01-22 19:43:57 +0000
commitd8b1fc8becf42da68ada51c0b666fee0719e8df7 (patch)
tree1323d9b339ed2bad34f659b4301ffa5f6ef75fee /app-editors
parentAdd kdebluetooth masked ebuilds that enables the irmcsynckonnector because it... (diff)
downloadhistorical-d8b1fc8becf42da68ada51c0b666fee0719e8df7.tar.gz
historical-d8b1fc8becf42da68ada51c0b666fee0719e8df7.tar.bz2
historical-d8b1fc8becf42da68ada51c0b666fee0719e8df7.zip
Add bash-completion script. For now this is vim-7 only. If it seems to work well, it'll be included in a later vim-6 revision.
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/ChangeLog6
-rw-r--r--app-editors/vim-core/Manifest9
-rw-r--r--app-editors/vim-core/files/xxd-completion25
3 files changed, 35 insertions, 5 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 8131d2a4cea5..6c17a6be27d5 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.127 2005/01/21 22:26:53 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.128 2005/01/22 19:43:57 ciaranm Exp $
+
+ 22 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> +files/xxd-completion:
+ Add bash-completion script. For now this is vim-7 only. If it seems to work
+ well, it'll be included in a later vim-6 revision.
*vim-core-6.3-r4 (21 Jan 2005)
diff --git a/app-editors/vim-core/Manifest b/app-editors/vim-core/Manifest
index 872bfdbe5833..a250100a4af4 100644
--- a/app-editors/vim-core/Manifest
+++ b/app-editors/vim-core/Manifest
@@ -1,7 +1,7 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 7feb3b9733f84776e5a5d10413ee6657 ChangeLog 17020
+MD5 8496b73ebf90221fce90699fe25969f5 ChangeLog 17227
MD5 37037241610822b80551fb3eba791b0f vim-core-7.0_alpha20050113.ebuild 838
MD5 5e9dc8a98f0d1234fb8c2324a385c8ab vim-core-6.3-r3.ebuild 901
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
@@ -10,11 +10,12 @@ MD5 0559e12807c0742ed95a93dc0d9dc7fb files/digest-vim-core-7.0_alpha20050113 156
MD5 fe3a85b7f303db551bfc5984738e1dfb files/digest-vim-core-6.3-r3 348
MD5 2ad354160ca3635ea115beb56e237e7c files/vimrc 3879
MD5 c2d0302eae7fc80b2a1cb38ddab9d3d3 files/rphillips-invalcolorpatch.diff 722
+MD5 ba542e54d91a04a85435253ae35301b6 files/xxd-completion 461
MD5 2fa89e2e9fd73c3778073f18e6836be8 files/digest-vim-core-6.3-r4 348
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFB8YHMLLFUmVNQ7rkRAg1WAJ0b+0qyGTZ5F2G6BgmLcDtt3mGxkACfYMd2
-mzmUVXNERQke1kEgL73SRBk=
-=/wqW
+iD8DBQFB8q0VLLFUmVNQ7rkRAtDcAJ4vAo3NMjcdxl0AbjrOlnVKB3ZsUwCgls3g
+LExTtVv846FG9omEmuQtIJA=
+=lqXX
-----END PGP SIGNATURE-----
diff --git a/app-editors/vim-core/files/xxd-completion b/app-editors/vim-core/files/xxd-completion
new file mode 100644
index 000000000000..174a4093f39f
--- /dev/null
+++ b/app-editors/vim-core/files/xxd-completion
@@ -0,0 +1,25 @@
+# Author: Ciaran McCreesh <ciaranm@gentoo.org>
+#
+# completion for xxd
+
+_xxd()
+{
+ local cur prev cmd args
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+ cmd=${COMP_WORDS[0]}
+
+ if [[ "${cur}" == -* ]] ; then
+ args='-a -b -c -E -g -h -i -l -ps -r -s -u -v'
+ COMPREPLY=( $( compgen -W "${args}" -- $cur ) )
+ else
+ _filedir
+ fi
+}
+
+complete -F _xxd xxd
+
+# vim: set ft=sh sw=4 et sts=4 :
+