summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-04 16:26:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-04 16:26:39 +0000
commit731139b45a70ce967bbbb6789c1616aa7f1e6159 (patch)
tree10351fa32ffab11c59c94115fa02dac1b18cc644 /app-emacs/apache-mode
parentUpdates (diff)
downloadhistorical-731139b45a70ce967bbbb6789c1616aa7f1e6159.tar.gz
historical-731139b45a70ce967bbbb6789c1616aa7f1e6159.tar.bz2
historical-731139b45a70ce967bbbb6789c1616aa7f1e6159.zip
initial
Diffstat (limited to 'app-emacs/apache-mode')
-rw-r--r--app-emacs/apache-mode/ChangeLog11
-rw-r--r--app-emacs/apache-mode/apache-mode-1.0.ebuild38
-rw-r--r--app-emacs/apache-mode/files/50apache-mode-gentoo.el10
-rw-r--r--app-emacs/apache-mode/files/digest-apache-mode-1.01
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/apache-mode/ChangeLog b/app-emacs/apache-mode/ChangeLog
new file mode 100644
index 000000000000..ea9154ee0b20
--- /dev/null
+++ b/app-emacs/apache-mode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/apache-mode
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apache-mode/ChangeLog,v 1.1 2002/11/04 16:26:39 mkennedy Exp $
+
+*apache-mode (04 Nov 2002)
+
+ 04 Nov 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ apache-mode-1.0.ebuild, files/50apache-mode-gentoo.el,
+ files/digest-apache-mode-1.0 :
+
+ Initial import.
diff --git a/app-emacs/apache-mode/apache-mode-1.0.ebuild b/app-emacs/apache-mode/apache-mode-1.0.ebuild
new file mode 100644
index 000000000000..14d0e42be3c9
--- /dev/null
+++ b/app-emacs/apache-mode/apache-mode-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apache-mode/apache-mode-1.0.ebuild,v 1.1 2002/11/04 16:26:39 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Major mode for editing Apache configuration files"
+HOMEPAGE="http://www.keelhaul.demon.co.uk/linux/#apachemode"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50apache-mode-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/apache-mode.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/apache-mode/files/50apache-mode-gentoo.el b/app-emacs/apache-mode/files/50apache-mode-gentoo.el
new file mode 100644
index 000000000000..463f57751b41
--- /dev/null
+++ b/app-emacs/apache-mode/files/50apache-mode-gentoo.el
@@ -0,0 +1,10 @@
+
+;;; apache-mode site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
+(autoload 'apache-mode "apache-mode" "autoloaded" t)
+(add-to-list 'auto-mode-alist '("\\.htaccess$" . apache-mode))
+(add-to-list 'auto-mode-alist '("httpd\\.conf$" . apache-mode))
+(add-to-list 'auto-mode-alist '("srm\\.conf$" . apache-mode))
+(add-to-list 'auto-mode-alist '("access\\.conf$" . apache-mode))
diff --git a/app-emacs/apache-mode/files/digest-apache-mode-1.0 b/app-emacs/apache-mode/files/digest-apache-mode-1.0
new file mode 100644
index 000000000000..6bedd2dd8b88
--- /dev/null
+++ b/app-emacs/apache-mode/files/digest-apache-mode-1.0
@@ -0,0 +1 @@
+MD5 b22017bd58b14ae20ee01b7c2219ead4 apache-mode-1.0.tar.bz2 3277