summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-03 08:55:58 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-03 08:55:58 +0000
commit81918e5a4452a2ddde82aab1fb6d5e629579682f (patch)
treefd33a26268ac6b3e8a3a2544369c3c2872928ef9 /app-emacs/python-mode
parentConvert to use linux-info eclass. (diff)
downloadhistorical-81918e5a4452a2ddde82aab1fb6d5e629579682f.tar.gz
historical-81918e5a4452a2ddde82aab1fb6d5e629579682f.tar.bz2
historical-81918e5a4452a2ddde82aab1fb6d5e629579682f.zip
Do not hardcode python path. Thanks to dan <reddan@warpmail.net>; bug #88770.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog6
-rw-r--r--app-emacs/python-mode/Manifest7
-rw-r--r--app-emacs/python-mode/files/setup.py3
-rw-r--r--app-emacs/python-mode/python-mode-4.63-r1.ebuild11
4 files changed, 19 insertions, 8 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 40a2359eb247..49e7fa76f978 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/python-mode
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.14 2005/04/30 19:09:57 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.15 2005/05/03 08:55:58 usata Exp $
+
+ 03 May 2005; Mamoru KOMACHI <usata@gentoo.org> +files/setup.py,
+ python-mode-4.63-r1.ebuild:
+ Do not hardcode python path. Thanks to dan <reddan@warpmail.net>; bug #88770.
30 Apr 2005; Michael Hanselmann <hansmi@gentoo.org>
python-mode-4.63-r1.ebuild:
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
index f94160611a52..d602b1f2a0b8 100644
--- a/app-emacs/python-mode/Manifest
+++ b/app-emacs/python-mode/Manifest
@@ -1,8 +1,9 @@
-MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
MD5 0ecb08054b678f7912068f673c5a2a54 python-mode-4.6.ebuild 773
-MD5 d2aeab1fc410f6961a38f4e6f8fa4002 ChangeLog 1626
-MD5 21a66ded47aba33202ab43f239452ed6 python-mode-4.63-r1.ebuild 881
+MD5 f62221159e366608d5439bb7e4850a92 ChangeLog 1802
+MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
+MD5 711dc65d123ffb27b7f8df92fe8dcf12 python-mode-4.63-r1.ebuild 880
MD5 7842a604f7fbeda6be9d9b86f6d143bb files/digest-python-mode-4.6 67
MD5 b16866ae5b915c74ccb69ff8591a4ada files/50python-mode-gentoo.el 334
MD5 2f5fc2b5c01b7202432d5e420db9d66b files/55python-mode-gentoo.el 505
+MD5 6d29bd6bc2d870795491141dcb821e06 files/setup.py 86
MD5 45d20c84f1cf40ffa73a3471d5e4ac6f files/digest-python-mode-4.63-r1 71
diff --git a/app-emacs/python-mode/files/setup.py b/app-emacs/python-mode/files/setup.py
new file mode 100644
index 000000000000..a08d125e3a25
--- /dev/null
+++ b/app-emacs/python-mode/files/setup.py
@@ -0,0 +1,3 @@
+from distutils.core import setup
+setup(name="pycomplete", py_modules=["pycomplete"])
+
diff --git a/app-emacs/python-mode/python-mode-4.63-r1.ebuild b/app-emacs/python-mode/python-mode-4.63-r1.ebuild
index 05ac16132091..2161510dc84e 100644
--- a/app-emacs/python-mode/python-mode-4.63-r1.ebuild
+++ b/app-emacs/python-mode/python-mode-4.63-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.63-r1.ebuild,v 1.6 2005/04/30 19:09:57 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.63-r1.ebuild,v 1.7 2005/05/03 08:55:58 usata Exp $
inherit distutils elisp
@@ -21,14 +21,17 @@ DEPEND="app-emacs/pymacs"
SITEFILE="55python-mode-gentoo.el"
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cp ${FILESDIR}/setup.py ${S}
+}
+
src_compile() {
elisp-comp *.el || die
}
src_install() {
+ distutils_src_install
elisp-install ${PN} *.el *.elc
- distutils_python_version
- insinto /usr/lib/python${PYVER}/site-packages
- doins pycomplete.py
elisp-site-file-install ${FILESDIR}/${SITEFILE}
}