summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-07-26 13:51:13 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-07-26 13:51:13 +0000
commit054062f60a66724578969fac680833a2bcb6ea42 (patch)
tree08c0c5545aca20db9e5a5ab3380ce4bed9807344 /app-emulation
parentAdded to ~ppc (diff)
downloadhistorical-054062f60a66724578969fac680833a2bcb6ea42.tar.gz
historical-054062f60a66724578969fac680833a2bcb6ea42.tar.bz2
historical-054062f60a66724578969fac680833a2bcb6ea42.zip
sysfs support added back
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog6
-rw-r--r--app-emulation/qemu-softmmu/Manifest5
-rw-r--r--app-emulation/qemu-softmmu/files/kqemu-0.7.1-sysfs.patch63
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild4
4 files changed, 73 insertions, 5 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 414c8993bae4..ca5bccf832bf 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.3 2005/07/26 08:06:05 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.4 2005/07/26 13:51:13 lu_zero Exp $
+
+ 26 Jul 2005; Luca Barbato <lu_zero@gentoo.org>
+ +files/kqemu-0.7.1-sysfs.patch, qemu-softmmu-0.7.1.ebuild:
+ updated the sysfs patch, thanks to Philippe Weibel <philippe.weibel@free.fr>
26 Jul 2005; Luca Barbato <lu_zero@gentoo.org> qemu-softmmu-0.7.1.ebuild:
Fixes and workarounds for the latest kernels.
diff --git a/app-emulation/qemu-softmmu/Manifest b/app-emulation/qemu-softmmu/Manifest
index ced3d5bf74bb..8803a5b8a2fe 100644
--- a/app-emulation/qemu-softmmu/Manifest
+++ b/app-emulation/qemu-softmmu/Manifest
@@ -1,8 +1,9 @@
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
-MD5 c9720995cb9c07c71ca8ba9d9a59ad79 qemu-softmmu-0.7.1.ebuild 3987
+MD5 159c47c6f540254c4f4318ed833ad4cb qemu-softmmu-0.7.1.ebuild 3992
MD5 754955c38d3fe7db22e4bb6842c93c05 qemu-softmmu-0.7.0-r1.ebuild 3956
-MD5 61a1cd678eb957ff7482085a5950f4f1 ChangeLog 719
+MD5 153048c85f2a8790fc470cfbe9cf0ad2 ChangeLog 909
MD5 f2e48bae97dad4e6e6bccdb212124ae0 files/digest-qemu-softmmu-0.7.0-r1 127
MD5 fd7335121f3422f52ac0dfe371ffb6b8 files/digest-qemu-softmmu-0.7.1 125
MD5 87ec2e1fa832612fb834d7dd49cf7e5c files/kqemu-sysfs.patch 2094
+MD5 1d5ef12a594467dced5bfce6c07ed893 files/kqemu-0.7.1-sysfs.patch 1631
MD5 3202f7445799cce82ccaac9749e1443d files/qemu-softmmu-0.7.0-errno.patch 487
diff --git a/app-emulation/qemu-softmmu/files/kqemu-0.7.1-sysfs.patch b/app-emulation/qemu-softmmu/files/kqemu-0.7.1-sysfs.patch
new file mode 100644
index 000000000000..1cd2cef22a23
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/kqemu-0.7.1-sysfs.patch
@@ -0,0 +1,63 @@
+--- kqemu.orig/kqemu-linux.c 2005-07-26 17:22:06.000000000 +0200
++++ kqemu/kqemu-linux.c 2005-07-26 17:21:20.000000000 +0200
+@@ -17,6 +17,11 @@
+ #include <asm/uaccess.h>
+ #include <asm/io.h>
+
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,0)
++#include <linux/device.h>
++static struct class_simple *kqemu_class;
++#endif
++#include <linux/devfs_fs_kernel.h>
+ #include "kqemu.h"
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,4,19)
+@@ -344,10 +349,38 @@
+ return ret;
+ }
+ }
++
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,0)
++ kqemu_class = class_simple_create(THIS_MODULE, "kqemu");
++
++ if (IS_ERR(kqemu_class)) {
++ ret = PTR_ERR(kqemu_class);
++ goto out_chrdev;
++ }
++
++ class_simple_device_add(kqemu_class, MKDEV(major, 0), NULL, "kqemu");
++
++#endif
++
++ ret = devfs_mk_cdev(MKDEV(major, 0),
++ S_IFCHR|S_IRUSR|S_IWUSR, "kqemu");
++ if (ret)
++ goto out_class;
++
+ printk("KQEMU installed, max_instances=%d max_locked_mem=%dkB.\n",
+ KQEMU_MAX_INSTANCES,
+ max_locked_pages * 4);
+ return 0;
++
++out_class:
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,0)
++ class_simple_device_remove(MKDEV(major,0));
++ class_simple_destroy(kqemu_class);
++#endif
++out_chrdev:
++ unregister_chrdev(major, "kqemu");
++
++ return ret;
+ }
+
+ void cleanup_module(void)
+@@ -356,4 +389,9 @@
+ unregister_chrdev(major, "kqemu");
+ else
+ misc_deregister (&kqemu_dev);
++ devfs_remove("kqemu");
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,0)
++ class_simple_device_remove(MKDEV(major, 0));
++ class_simple_destroy(kqemu_class);
++#endif
+ }
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild
index 16e1f66ad3ef..fdc3f4d636a7 100644
--- a/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild,v 1.2 2005/07/26 08:06:05 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1.ebuild,v 1.3 2005/07/26 13:51:13 lu_zero Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -56,7 +56,7 @@ src_unpack() {
einfo "if you want it released under GPL"
mv ${S}/../kqemu ${S}
cd ${S}/kqemu
- #epatch ${FILESDIR}/kqemu-sysfs.patch
+ epatch ${FILESDIR}/kqemu-${PV}-sysfs.patch
sed -i -e "s:#ifndef PAGE_KERNEL_EXEC:#if 1:" ${S}/kqemu/kqemu-linux.c
fi
# if use qvm86; then