summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-05-01 11:07:30 +0000
committerMamoru Komachi <usata@gentoo.org>2004-05-01 11:07:30 +0000
commit99ac67c7969f2823da3481b03af19f01fec235b8 (patch)
tree8970d48315d157c01aeb27966abc63233b2e79a7 /app-i18n/skkfep
parentAdd new Version 0.10.3, correct IUSE and HOMEPAGE in older ebuilds. (diff)
downloadhistorical-99ac67c7969f2823da3481b03af19f01fec235b8.tar.gz
historical-99ac67c7969f2823da3481b03af19f01fec235b8.tar.bz2
historical-99ac67c7969f2823da3481b03af19f01fec235b8.zip
Initial import.
Diffstat (limited to 'app-i18n/skkfep')
-rw-r--r--app-i18n/skkfep/ChangeLog9
-rw-r--r--app-i18n/skkfep/Manifest2
-rw-r--r--app-i18n/skkfep/files/digest-skkfep-0.86c2
-rw-r--r--app-i18n/skkfep/metadata.xml5
-rw-r--r--app-i18n/skkfep/skkfep-0.86c.ebuild52
5 files changed, 70 insertions, 0 deletions
diff --git a/app-i18n/skkfep/ChangeLog b/app-i18n/skkfep/ChangeLog
new file mode 100644
index 000000000000..984571923269
--- /dev/null
+++ b/app-i18n/skkfep/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-i18n/skkfep
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkfep/ChangeLog,v 1.1 2004/05/01 11:03:35 usata Exp $
+
+*skkfep-0.86c (01 May 2004)
+
+ 01 May 2004; Mamoru KOMACHI <usata@gentoo.org> skkfep-0.86c.ebuild:
+ Initial import.
+
diff --git a/app-i18n/skkfep/Manifest b/app-i18n/skkfep/Manifest
new file mode 100644
index 000000000000..9e31050918d5
--- /dev/null
+++ b/app-i18n/skkfep/Manifest
@@ -0,0 +1,2 @@
+MD5 9ebbc6d9f7638b5a5a8e2b8c6800f4df skkfep-0.86c.ebuild 1172
+MD5 48df17230bebc2d2ccb335f709694d2b files/digest-skkfep-0.86c 135
diff --git a/app-i18n/skkfep/files/digest-skkfep-0.86c b/app-i18n/skkfep/files/digest-skkfep-0.86c
new file mode 100644
index 000000000000..107b17b9929a
--- /dev/null
+++ b/app-i18n/skkfep/files/digest-skkfep-0.86c
@@ -0,0 +1,2 @@
+MD5 0e06d473b70bd0233e25195e062bb663 skkfep0.86c.tar.gz 46748
+MD5 6878933a826167aa576f413fa6b37d35 skkfep0.86c-kh1.2.10.patch.gz 30234
diff --git a/app-i18n/skkfep/metadata.xml b/app-i18n/skkfep/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/app-i18n/skkfep/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/app-i18n/skkfep/skkfep-0.86c.ebuild b/app-i18n/skkfep/skkfep-0.86c.ebuild
new file mode 100644
index 000000000000..e38b9e7891cd
--- /dev/null
+++ b/app-i18n/skkfep/skkfep-0.86c.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkfep/skkfep-0.86c.ebuild,v 1.1 2004/05/01 11:03:35 usata Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P=${P/-/}
+KH_PV="kh1.2.10"
+
+DESCRIPTION="A SKK-like Japanese input method for console"
+SRC_URI="http://www1.interq.or.jp/~deton/jvim-skk/${MY_P}.tar.gz
+ http://www1.interq.or.jp/~deton/jvim-skk/${MY_P}-${KH_PV}.patch.gz"
+HOMEPAGE="http://homepage2.nifty.com/aito/soft.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/sed-4
+ sys-apps/gawk
+ sys-libs/ncurses"
+RDEPEND="virtual/skkserv"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+
+ unpack ${A}
+ epatch ${MY_P}-${KH_PV}.patch
+}
+
+src_compile() {
+
+ sed -i -e 's/solaris2/linux/' \
+ -e '/^#define USE_SKKSRCH/s/^/\/* /' \
+ -e '/^#define BOTH_SERVER_AND_SKKSRCH/s/^/\/* /' \
+ -e '/SUSPEND_FEP/s/^\/\*//' config.h
+ sed -i -e 's/termcap/curses/' \
+ -e '/skksrch/s/skksrch\.[co]//' protoMakefile
+ make || die "make failed."
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe skkfep
+ doman skkfep.1
+
+ dodoc README* HISTORY INSTALL TODO
+}