summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-04-07 15:21:40 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-04-07 15:21:40 +0000
commitaa0a4b4781de99a7720cf6f3da59413843d881e5 (patch)
treef00753782dea50e18e2cdc39ed1b556c4ed5b0a7 /app-misc/devtodo/files
parentRemove ebuild calling libtoolize directly wrt bug #160005. (diff)
downloadhistorical-aa0a4b4781de99a7720cf6f3da59413843d881e5.tar.gz
historical-aa0a4b4781de99a7720cf6f3da59413843d881e5.tar.bz2
historical-aa0a4b4781de99a7720cf6f3da59413843d881e5.zip
Fix bug #138412 and bug #160154 , wipe old ebuilds and set me up as maintainer since ka0ttic is gone. Also bumping -r2 to stable as it's more or less a bash-completion modification which is safe
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'app-misc/devtodo/files')
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff146
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.19-r23
2 files changed, 149 insertions, 0 deletions
diff --git a/app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff b/app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff
new file mode 100644
index 000000000000..7c55f0e7f031
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff
@@ -0,0 +1,146 @@
+diff -urN devtodo-0.1.18.orig/acconfig.h devtodo-0.1.18/acconfig.h
+--- devtodo-0.1.18.orig/acconfig.h 2004-12-17 10:21:09.168345388 -0500
++++ devtodo-0.1.18/acconfig.h 1969-12-31 19:00:00.000000000 -0500
+@@ -1,6 +0,0 @@
+-/* System configuration directory */
+-#undef SYSCONFDIR
+-
+-/* Use termcap to get terminal width */
+-#undef USETERMCAP
+-@TOP@
+diff -urN devtodo-0.1.18.orig/configure.in devtodo-0.1.18/configure.in
+--- devtodo-0.1.18.orig/configure.in 2004-12-17 10:21:09.166345721 -0500
++++ devtodo-0.1.18/configure.in 2004-12-17 10:21:34.049210408 -0500
+@@ -25,7 +25,7 @@
+ # Don't use termcap to obtain window size
+ AC_ARG_WITH(termcap, [ --without-termcap don't use termcap to obtain terminal width])
+ if test "${with_termcap}_" = _ -o "${with_termcap}_" = yes; then
+- AC_DEFINE(USETERMCAP)
++ AC_DEFINE(USETERMCAP, [], [Use termcap?])
+ fi
+
+ # Check for various headers and functions - although I'm not doing anything
+@@ -79,7 +79,7 @@
+ AC_SUBST(READLINE_LIBS)
+
+ SYSCONFDIR="`eval echo $sysconfdir`"
+-AC_DEFINE_UNQUOTED(SYSCONFDIR, "$SYSCONFDIR")
++AC_DEFINE_UNQUOTED(SYSCONFDIR, "$SYSCONFDIR", [System configuration directory])
+ AC_SUBST(SYSCONFDIR)
+
+ AC_CHECK_PROG(HAVE_CRASH_CONFIG, crash-config, yes)
+diff -urN devtodo-0.1.18.orig/doc/devtodo.1.in devtodo-0.1.18/doc/devtodo.1.in
+--- devtodo-0.1.18.orig/doc/devtodo.1.in 2004-12-17 10:21:09.135350872 -0500
++++ devtodo-0.1.18/doc/devtodo.1.in 2004-12-17 10:21:34.050210242 -0500
+@@ -20,9 +20,6 @@
+ .TP
+ \fBtdd \fI<indices>\fP\fP
+ Mark the specified items as being done.
+-.TP
+-\fBtdl [\-g \fI<index>\fP] \fI<database>\fP\fP
+-Link the specified devtodo database into the current one, optionally grafting it as a child of the specified index.
+ .SH "DESCRIPTION"
+ .LP
+ \fBtodo\fP is a program aimed specifically at programmers (but usable by anybody at the terminal) to aid in day\-to\-day development.
+@@ -372,6 +369,10 @@
+ .TP
+ \fB~/.todorc\fR
+ User-specific options are specified in this file. Please refer to the section \fBTODORC\fR for more information.
++.SH "BUGS"
++.LP
++Because of a conflict with app-misc/tdl, the tdl symbolic link and the tdl manual page have been removed.
++See \fIhttp://bugs.gentoo.org/show_bug.cgi?id=55371\fR for more information.
+ .SH "AUTHORS"
+ .LP
+ Alec Thomas \fI<alec@swapoff.org>\fR
+diff -urN devtodo-0.1.18.orig/doc/Makefile.am devtodo-0.1.18/doc/Makefile.am
+--- devtodo-0.1.18.orig/doc/Makefile.am 2004-12-17 10:21:09.135350872 -0500
++++ devtodo-0.1.18/doc/Makefile.am 2004-12-17 10:21:34.050210242 -0500
+@@ -1,5 +1,5 @@
+ man_MANS=devtodo.1
+-manlinks=tda tdr tdd tde tdl todo
++manlinks=tda tdr tdd tde todo
+
+ install-data-local:
+ mkdir -p $(DESTDIR)$(mandir)/man1
+diff -urN devtodo-0.1.18.orig/src/Makefile.am devtodo-0.1.18/src/Makefile.am
+--- devtodo-0.1.18.orig/src/Makefile.am 2004-12-17 10:21:09.154347715 -0500
++++ devtodo-0.1.18/src/Makefile.am 2004-12-17 10:21:34.053209744 -0500
+@@ -1,18 +1,12 @@
+ bin_PROGRAMS=devtodo
+ devtodo_SOURCES=Todo.cc Todo.h TodoDB.cc TodoDB.h support.cc support.h \
+ main.cc todoterm.cc todoterm.h Loaders.cc Loaders.h todorl.h
+-binlinks=tda tdr tdd tdl tde todo
++binlinks=tda tdr tdd tde todo
+
+ devtodo_LDADD=../util/libutil.la
+ INCLUDES=-I../util
+ LIBS=@READLINE_LIBS@
+
+-if DEBUG
+-CPPFLAGS=-g
+-else
+-CPPFLAGS+=-DNDEBUG
+-endif
+-
+ install-exec-hook:
+ cd $(DESTDIR)$(bindir); for i in $(binlinks); do $(LN_S) -f devtodo $$i; done
+
+diff -urN devtodo-0.1.18.orig/src/TodoDB.cc devtodo-0.1.18/src/TodoDB.cc
+--- devtodo-0.1.18.orig/src/TodoDB.cc 2004-12-17 10:21:09.136350706 -0500
++++ devtodo-0.1.18/src/TodoDB.cc 2004-12-17 10:21:34.054209577 -0500
+@@ -949,7 +948,11 @@
+ if (out.bad())
+ throw exception("couldn't open TODO for generation");
+
+- if (titleText != "") wraptext(out, titleText, 0, options.columns);
++ if (titleText != "") {
++ wraptext(out, titleText, 0, options.columns);
++ out << endl << endl;
++ }
++
+ if (options.verbose > 1)
+ cout << "todo: generating using format '" << options.format["verbose-generated"] << "'" << endl;
+ filterView();
+diff -urN devtodo-0.1.18.orig/util/c_regex.h devtodo-0.1.18/util/c_regex.h
+--- devtodo-0.1.18.orig/util/c_regex.h 2004-12-17 10:21:09.157347216 -0500
++++ devtodo-0.1.18/util/c_regex.h 2004-12-17 10:25:41.026169344 -0500
+@@ -533,7 +533,10 @@
+ /* For now unconditionally define __restrict_arr to expand to nothing.
+ Ideally we would have a test for the compiler which allows defining
+ it to restrict. */
+-#define __restrict_arr
++#ifdef __restrict_arr
++# undef __restrict_arr
++# define __restrict_arr
++#endif
+
+ /* POSIX compatibility. */
+ extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
+--- devtodo-0.1.19/contrib/devtodo.bash-completion {cset 9b4d9f02-fdb7-4641-b07f-7359b794d6b0}
++++ devtodo-0.1.19/contrib/devtodo.bash-completion {local clone}
+@@ -35,6 +35,6 @@ _devtodo() {
+ ;;
+ esac
+ }
+-complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd tdl
++complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd
+
+ # vim: set ft=sh tw=80 sw=4 et :
+--- devtodo-0.1.19/src/support.cc {cset 5f5bd9cb-18fb-4046-bff5-4f3dbd781e47}
++++ devtodo-0.1.19/src/support.cc {local clone}
+@@ -289,11 +289,10 @@ enum { Help = -100, Remove, Version, Tit
+ << "Where <arguments> can be any of the following:" << endl;
+ args.displayHelp(cout, options.columns);
+ cout << endl
+- << "In addition, there are five convenience symlinks. These are 'tda', 'tdr'," << endl
+- << "'tdd', 'tde', and 'tdl'. For 'tde', 'tdd' and 'tdr' supply an index to edit," << endl
++ << "In addition, there are four convenience symlinks. These are 'tda', 'tdr'," << endl
++ << "'tdd', and 'tde'. For 'tde', 'tdd' and 'tdr' supply an index to edit," << endl
+ << "mark done and remove respectively. For 'tda' supply the text of the todo item" << endl
+- << "item and optionally the priority. For 'tdl' supply the path to another todo" << endl
+- << "file to link in to the current todo file." << endl
++ << "item and optionally the priority." << endl
+ << "eg. tde 1" << endl;
+ exit(0);
+ break;
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.19-r2 b/app-misc/devtodo/files/digest-devtodo-0.1.19-r2
new file mode 100644
index 000000000000..980082f5be41
--- /dev/null
+++ b/app-misc/devtodo/files/digest-devtodo-0.1.19-r2
@@ -0,0 +1,3 @@
+MD5 723c86eae76c425ab9f271760bb951a3 devtodo-0.1.19.tar.gz 442920
+RMD160 133140acde8a3fdd9f055460c28926f60873aeb3 devtodo-0.1.19.tar.gz 442920
+SHA256 36d90650441f9cea7b144700676547b7a0ea2f18e664242deb7ce1820b463599 devtodo-0.1.19.tar.gz 442920