summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 03:45:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 03:45:42 +0000
commited34e375961396c31c32ea54685059966d51665e (patch)
tree318409b3268d5b5cf241ef4ccc6ea1c977e22b7c /app-misc/devtodo
parentQA - fix use invocation (diff)
downloadhistorical-ed34e375961396c31c32ea54685059966d51665e.tar.gz
historical-ed34e375961396c31c32ea54685059966d51665e.tar.bz2
historical-ed34e375961396c31c32ea54685059966d51665e.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/devtodo')
-rw-r--r--app-misc/devtodo/devtodo-0.1.17.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.17.ebuild b/app-misc/devtodo/devtodo-0.1.17.ebuild
index 0a701c1bbccf..ecfbeed2b5b0 100644
--- a/app-misc/devtodo/devtodo-0.1.17.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.17.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.17.ebuild,v 1.13 2004/06/28 01:15:52 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.17.ebuild,v 1.14 2004/06/28 03:31:19 vapier Exp $
inherit eutils gnuconfig
-IUSE=""
DESCRIPTION="A nice command line todo list for developers"
HOMEPAGE="http://devtodo.sourceforge.net/"
SRC_URI="http://devtodo.sourceforge.net/${PV}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha ~hppa mips amd64 ~ia64 s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha ~hppa amd64 ~ia64 s390"
+IUSE=""
DEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.1"
@@ -19,21 +19,18 @@ DEPEND=">=sys-libs/ncurses-5.2
src_unpack() {
unpack ${A}
cd ${S}
-
# Patch to allow compilation with gcc-3.3
epatch ${FILESDIR}/${PN}.patch
}
src_compile() {
gnuconfig_update
-
- econf \
- --sysconfdir=/etc/devtodo || die
+ econf --sysconfdir=/etc/devtodo || die
emake || die
}
src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog QuickStart README TODO
+ dodoc AUTHORS ChangeLog QuickStart README TODO
dodoc doc/scripts.sh doc/scripts.tcsh doc/todorc.example contrib/tdrec
}