summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-06-08 12:03:52 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-06-08 12:03:52 +0000
commit4780ec76eea6e3c35e2e6aa513338b8049879581 (patch)
tree7d1aad8aa12673b1006c1659e771e6ac3b34b6e8 /app-office/openoffice-bin
parentFix the printing issue of openoffice-1.0.3 (diff)
downloadhistorical-4780ec76eea6e3c35e2e6aa513338b8049879581.tar.gz
historical-4780ec76eea6e3c35e2e6aa513338b8049879581.tar.bz2
historical-4780ec76eea6e3c35e2e6aa513338b8049879581.zip
Fix the printing issue of openoffice-1.0.3
Diffstat (limited to 'app-office/openoffice-bin')
-rw-r--r--app-office/openoffice-bin/Manifest4
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.0.3.12
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild223
3 files changed, 227 insertions, 2 deletions
diff --git a/app-office/openoffice-bin/Manifest b/app-office/openoffice-bin/Manifest
index d4592e43f14c..ce7b47671bc8 100644
--- a/app-office/openoffice-bin/Manifest
+++ b/app-office/openoffice-bin/Manifest
@@ -1,9 +1,9 @@
-MD5 c19fc6125b8305f3398e4b3e35385258 ChangeLog 3521
+MD5 d10b24e8de8b37c256245e339dc1ad49 ChangeLog 3800
MD5 583bb2a3fcf66696f1c3c389874b82c9 openoffice-bin-1.0.0-r3.ebuild 2912
MD5 b221cf945d38e9e31215107f8d084063 openoffice-bin-1.0.1.ebuild 5603
MD5 7641bbaef9471705b1ed80f92485d707 openoffice-bin-1.0.2.ebuild 6176
MD5 d75508db43d161514ce1f1288c5d67d2 openoffice-bin-1.0.3.ebuild 6177
-MD5 2b2251e251468fa0ec62411ab9c4a482 openoffice-bin-1.0.3.1.ebuild 6416
+MD5 286e13ebb4c41e2b2a502ac3b12fa6b4 openoffice-bin-1.0.3.1.ebuild 6448
MD5 ceb4d00de66bf00ce512ed115b798a4e openoffice-bin-1.1_beta-r1.ebuild 5977
MD5 1d8dc5e17ece7fe099b2297b2fe64d04 openoffice-bin-1.1_beta.ebuild 5963
MD5 9f6fa2caffbec422160157fb68966b37 files/digest-openoffice-bin-1.0.0-r3 82
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.3.1 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.3.1
new file mode 100644
index 000000000000..bba108656522
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.3.1
@@ -0,0 +1,2 @@
+MD5 f6432789caaff728924f46ee65f86822 OOo_1.0.3_LinuxIntel_install.tar.gz 72429466
+MD5 404abdc6d5778956ce7f79dd1dc60d31 libvcl641li.so.gz 1480647
diff --git a/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild b/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild
new file mode 100644
index 000000000000..7750a0b72b1d
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild,v 1.1 2003/06/08 12:03:44 pauldv Exp $
+
+IUSE="kde gnome"
+
+inherit virtualx
+
+# NOTE: There are two big issues that should be addressed.
+#
+# 1) Language support and fonts should be addressed.
+
+LOC="/opt"
+
+INSTDIR="${LOC}/OpenOffice.org${PV//.1/}"
+MY_PV="`echo ${PV//.1/} | gawk '{ print toupper($1) }'`"
+
+if [ `use ppc` ]; then
+ MY_P="OOo_${MY_PV}_LinuxPowerPC_installer"
+ S="${WORKDIR}/${MY_P}"
+else
+ MY_P="OOo_${MY_PV}_LinuxIntel_install"
+ S="${WORKDIR}/install"
+fi;
+
+DESCRIPTION="OpenOffice productivity suite"
+SRC_URI="x86? ( http://ny1.mirror.openoffice.org/stable/${PV//.1/}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
+ http://sf1.mirror.openoffice.org/stable/${PV//.1/}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
+ http://vlaai.snt.utwente.nl/pub/software/openoffice/stable/${PV//.1/}/libvcl641li.so.gz )
+ ppc? ( ftp://ftp.yellowdoglinux.com/pub/yellowdog/software/openoffice/OOo_${MY_PV}_LinuxPowerPC_installer.tar.gz )"
+HOMEPAGE="http://www.openoffice.org"
+
+DEPEND="virtual/glibc
+ >=dev-lang/perl-5.0
+ virtual/x11
+ app-arch/zip
+ app-arch/unzip
+ || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
+ !app-office/openoffice"
+
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc "
+
+src_install() {
+
+ # Sandbox issues; bug #8587
+ addpredict "/user"
+ addpredict "/share"
+
+ # Sandbox issues; bug 8063
+ addpredict "/dev/dri"
+
+ # Autoresponse file for main installation
+ cat > ${T}/rsfile-global <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_NETWORK
+ INSTALLATIONTYPE=STANDARD
+ DESTINATIONPATH=<destdir>
+ OUTERPATH=
+ LOGFILE=
+ LANGUAGELIST=<LANGUAGE>
+
+ [JAVA]
+ JavaSupport=preinstalled_or_none
+ END_RS
+
+ # Autoresponse file for user isntallation
+ cat > ${T}/rsfile-local <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_WORKSTATION
+ INSTALLATIONTYPE=WORKSTATION
+ DESTINATIONPATH=<home>/.openoffice/<pv>
+
+ [JAVA]
+ JavaSupport=none
+ END_RS
+
+ # Fixing install location in response file
+ sed -e "s|<destdir>|${D}${INSTDIR}|" \
+ ${T}/rsfile-global > ${T}/autoresponse
+
+ einfo "Installing OpenOffice.org into build root..."
+ dodir ${INSTDIR}
+ cd ${S}
+ # Setup virtualmake
+ export maketype="./setup"
+ # We need X to install...
+ virtualmake "-v -r:${T}/autoresponse"
+
+ #fix the libstdc++.so symlink
+ cd ${D}/${INSTDIR}/program
+ ln -sf libstdc++.so.3.0.4 libstdc++.so.3
+ ln -sf libstdc++.so.3.0.4 libstdc++
+
+ echo
+ einfo "Removing build root from registry..."
+ # Remove totally useless stuff.
+ rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh}
+ # Remove build root from registry and co
+ egrep -rl "${D}" ${D}${INSTDIR}/* | \
+ xargs -i perl -pi -e "s|${D}||g" {} || :
+
+ einfo "Fixing permissions..."
+ # Fix permissions
+ find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
+ chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
+
+ # Fix symlinks
+ for x in "soffice program/spadmin" \
+ "program/setup setup" \
+ "program/spadmin spadmin"
+ do
+ dosym $(echo ${x} | awk '{print $1}') \
+ ${INSTDIR}/$(echo ${x} | awk '{print $2}')
+ done
+
+ # Install user autoresponse file
+ insinto /etc/openoffice
+ sed -e "s|<pv>|${PV//.1/}|g" ${T}/rsfile-local > ${T}/autoresponse.conf
+ doins ${T}/autoresponse.conf
+
+ # Install wrapper script
+ exeinto /usr/bin
+ sed -e "s|<pv>|${PV//.1/}|g" \
+ ${FILESDIR}/${PV//.1/}/ooffice-wrapper-1.3 > ${T}/ooffice
+ doexe ${T}/ooffice
+ # Component symlinks
+ dosym ooffice /usr/bin/oocalc
+ dosym ooffice /usr/bin/oodraw
+ dosym ooffice /usr/bin/ooimpress
+ dosym ooffice /usr/bin/oomath
+ dosym ooffice /usr/bin/oowriter
+ dosym ooffice /usr/bin/oosetup
+ dosym ooffice /usr/bin/oopadmin
+
+ einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
+ if [ -n "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/apps/OpenOffice.org
+ # Install the files needed for the catagory
+ doins ${D}${INSTDIR}/share/gnome/net/.directory
+ doins ${D}${INSTDIR}/share/gnome/net/.order
+
+ for x in ${D}${INSTDIR}/share/gnome/net/*.desktop
+ do
+ # We have to handle setup differently
+ perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ # Now fix the rest
+ perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ doins ${x}
+ done
+ fi
+
+ if [ -n "`use kde`" ]
+ then
+ local kdeloc="${D}${INSTDIR}/share/kde/net/applnk/OpenOffice.org${PV//.1/}"
+
+ # Portage do not work with the space ..
+ mv ${D}${INSTDIR}/share/kde/net/applnk/OpenOffice.org\ ${PV//.1/} ${kdeloc}
+
+ insinto /usr/share/applnk/OpenOffice.org
+ # Install the files needed for the catagory
+ doins ${kdeloc}/.directory
+ doins ${kdeloc}/.order
+ dodir /usr/share
+ # Install the icons and mime info
+ cp -a ${D}${INSTDIR}/share/kde/net/mimelnk/share/* ${D}/usr/share
+
+ for x in ${kdeloc}/*.desktop
+ do
+ # We have to handle setup differently
+ perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ # Now fix the rest
+ perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ doins ${x}
+ done
+ fi
+
+ # Unneeded, as they get installed into /usr/share...
+ rm -rf ${D}${INSTDIR}/share/{cde,gnome,kde}
+
+ for f in ${D}/usr/share/gnome/apps/OpenOffice.org/* ; do
+ echo 'Categories=Application;Office;' >> ${f}
+ done
+
+
+ # Make sure these do not get nuked.
+ keepdir ${INSTDIR}/user/config/registry/instance/org/openoffice/{Office,ucb}
+ keepdir ${INSTDIR}/user/psprint/{driver,fontmetric}
+ keepdir ${INSTDIR}/user/{autocorr,backup,plugin,store,temp,template}
+
+ #Apply printing patch.
+ cp ${DISTDIR}/libvcl641li.so.gz ${D}${INSTDIR}/program
+ gunzip -f ${D}/${INSTDIR}/program/libvcl641li.so.gz
+}
+
+pkg_preinst() {
+
+ # The one with OO-1.0.0 was not valid
+ if [ -f ${ROOT}/etc/openoffice/autoresponse.conf ]
+ then
+ rm -f ${ROOT}/etc/openoffice/autoresponse.conf
+ fi
+}
+
+pkg_postinst() {
+
+ einfo "******************************************************************"
+ einfo " To start OpenOffice.org, run:"
+ einfo
+ einfo " $ ooffice"
+ einfo
+ einfo " Also, for individual components, you can use any of:"
+ einfo
+ einfo " oocalc, oodraw, ooimpress, oomath or oowriter"
+ einfo
+ einfo " If the fonts appear garbled in the user interface refer to "
+ einfo " Bug 8539, or http://www.openoffice.org/FAQs/fontguide.html#8"
+ einfo
+ einfo "******************************************************************"
+}
+