summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-10-14 12:30:12 +0000
committerAchim Gottinger <achim@gentoo.org>2000-10-14 12:30:12 +0000
commit55f7e02effa0e330dba940ab6be9a49fb83b0c3c (patch)
tree5d988b37539b99a27910f26ecc4db17fbeabfe76 /app-office
parent*** empty log message *** (diff)
downloadhistorical-55f7e02effa0e330dba940ab6be9a49fb83b0c3c.tar.gz
historical-55f7e02effa0e330dba940ab6be9a49fb83b0c3c.tar.bz2
historical-55f7e02effa0e330dba940ab6be9a49fb83b0c3c.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/dia/dia-0.86.ebuild10
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.561
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.571
-rw-r--r--app-office/gnumeric/gnumeric-0.57.ebuild (renamed from app-office/gnumeric/gnumeric-0.56.ebuild)12
4 files changed, 14 insertions, 10 deletions
diff --git a/app-office/dia/dia-0.86.ebuild b/app-office/dia/dia-0.86.ebuild
index 0a208e4e751a..e7e896e09db5 100644
--- a/app-office/dia/dia-0.86.ebuild
+++ b/app-office/dia/dia-0.86.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.86.ebuild,v 1.4 2000/09/15 20:08:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.86.ebuild,v 1.5 2000/10/14 12:30:11 achim Exp $
-P=dia-0.86
A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Diagram Creation Program"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/dia/${A}"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
src_compile() {
cd ${S}
-try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-catgets
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-catgets --enable-gnome --enable-gnome-print
+ # bonobo support does not work yet
try make
}
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.56 b/app-office/gnumeric/files/digest-gnumeric-0.56
deleted file mode 100644
index 412cfeff0466..000000000000
--- a/app-office/gnumeric/files/digest-gnumeric-0.56
+++ /dev/null
@@ -1 +0,0 @@
-MD5 674581cf58fc5b5158fb5103327955be gnumeric-0.56.tar.gz
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.57 b/app-office/gnumeric/files/digest-gnumeric-0.57
new file mode 100644
index 000000000000..d06b6ceb0832
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-0.57
@@ -0,0 +1 @@
+MD5 abe5002a4b812c86c85363cc24ac3a8a gnumeric-0.57.tar.gz
diff --git a/app-office/gnumeric/gnumeric-0.56.ebuild b/app-office/gnumeric/gnumeric-0.57.ebuild
index 84b09f7ae054..76dc92b8385d 100644
--- a/app-office/gnumeric/gnumeric-0.56.ebuild
+++ b/app-office/gnumeric/gnumeric-0.57.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.56.ebuild,v 1.3 2000/09/15 20:08:58 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.57.ebuild,v 1.1 2000/10/14 12:30:12 achim Exp $
-P=gnumeric-0.56
A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="gnumeric"
@@ -12,8 +11,13 @@ HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
src_compile() {
cd ${S}
- try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-catgets --without-bonobo
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-catgets --without-bonobo --with-gb
+ cd plugins/perl
+ cp Makefile Makefile.orig
+ sed -e "s:perl Makefile\.PL:perl Makefile\.PL $PERLINSTALL:" \
+ Makefile.orig > Makefile
+ cd ${S}
try make
}