summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-21 19:19:19 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-21 19:19:19 +0000
commitc88c97525033195aa9d405a0b60d8b2a0f115c1d (patch)
tree439938e37571b3502229cb130e041ab7628f20b3 /app-office
parent*** empty log message *** (diff)
downloadhistorical-c88c97525033195aa9d405a0b60d8b2a0f115c1d.tar.gz
historical-c88c97525033195aa9d405a0b60d8b2a0f115c1d.tar.bz2
historical-c88c97525033195aa9d405a0b60d8b2a0f115c1d.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/gnumeric-0.61.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-office/gnumeric/gnumeric-0.61.ebuild b/app-office/gnumeric/gnumeric-0.61.ebuild
new file mode 100644
index 000000000000..e2db7c877767
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-0.61.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.61.ebuild,v 1.1 2000/12/21 19:19:19 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=sys-devel/perl-5
+ >=virtual/python-1.5.2
+ >=gnome-base/gal-0.2.2
+ >=gnome-libs/gb-0.0.15
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28
+ >=gnome-libs/libgda-0.2.0 ) "
+
+src_compile() {
+ cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ ${myconf} --with-gb
+ cd plugins/perl
+ cp Makefile Makefile.orig
+# sed -e "s:perl Makefile\.PL:perl Makefile\.PL $PERLINSTALL:" \
+# Makefile.orig > Makefile
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+