summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-10-31 19:22:55 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-10-31 19:22:55 +0000
commit1c84100545ce6c07af01177a83fd83947847315f (patch)
tree8ed64bf0c79d9ac405150dc8b178ee9e54f3f8ad /app-sci/mpqc
parentfixed masking of qt-3.1.0 (typo) (diff)
downloadhistorical-1c84100545ce6c07af01177a83fd83947847315f.tar.gz
historical-1c84100545ce6c07af01177a83fd83947847315f.tar.bz2
historical-1c84100545ce6c07af01177a83fd83947847315f.zip
initial ebuild
Diffstat (limited to 'app-sci/mpqc')
-rw-r--r--app-sci/mpqc/ChangeLog8
-rw-r--r--app-sci/mpqc/files/digest-mpqc-2.1.22
-rw-r--r--app-sci/mpqc/mpqc-2.1.2.ebuild40
3 files changed, 50 insertions, 0 deletions
diff --git a/app-sci/mpqc/ChangeLog b/app-sci/mpqc/ChangeLog
new file mode 100644
index 000000000000..d04ae752051e
--- /dev/null
+++ b/app-sci/mpqc/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-sci/mpqc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/ChangeLog,v 1.1 2002/10/31 19:22:55 hannes Exp $
+
+*mpqc-2.1.2 (31 Oct 2002)
+
+ 31 Oct 2002; Hannes Mehnert <hannes@gentoo.org> mpqc-2.1.2.ebuild,
+ ChangeLog: Initial ebuild.
diff --git a/app-sci/mpqc/files/digest-mpqc-2.1.2 b/app-sci/mpqc/files/digest-mpqc-2.1.2
new file mode 100644
index 000000000000..d544edb81f84
--- /dev/null
+++ b/app-sci/mpqc/files/digest-mpqc-2.1.2
@@ -0,0 +1,2 @@
+MD5 37c9926b5e4bfadefa0ffb07033763f4 mpqc-2.1.2.tar.gz 1780961
+MD5 856749d3f5b65041228b442441baefe9 mpqc-man-2.1.2.tar.gz 123704
diff --git a/app-sci/mpqc/mpqc-2.1.2.ebuild b/app-sci/mpqc/mpqc-2.1.2.ebuild
new file mode 100644
index 000000000000..8b86298379d1
--- /dev/null
+++ b/app-sci/mpqc/mpqc-2.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/mpqc/mpqc-2.1.2.ebuild,v 1.1 2002/10/31 19:22:55 hannes Exp $
+
+SLOT="0"
+HOMEPAGE="http://aros.ca.sandia.gov/~cljanss/mpqc/"
+SRC_URI="http://aros.ca.sandia.gov/~cljanss/mpqc/distrib/${P}.tar.gz
+ doc? ( http://aros.ca.sandia.gov/~cljanss/mpqc/distrib/${PN}-man-${PV}.tar.gz )"
+DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
+LICENSE="GPL"
+KEYWORDS="~x86"
+IUSE="doc X"
+
+DEPEND="sys-devel/flex
+ app-sci/blas
+ app-sci/lapack
+ sys-devel/perl
+ X? ( x11-base/xfree )"
+
+src_compile() {
+ CFLAGS_SAVE=${CFLAGS}; CXXFLAGS_SAVE=${CXXFLAGS}
+ myconf="${myconf} --prefix=/usr"
+ use X && myconf="${myconf} --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib"
+ ./configure ${myconf}
+ sed -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS_SAVE}:" \
+ -e "s:^FFLAGS =.*$:FFLAGS=${CFLAGS_SAVE}:" \
+ -e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS_SAVE}:" \
+ lib/LocalMakefile > lib/LocalMakefile.foo
+ mv lib/LocalMakefile.foo lib/LocalMakefile
+ emake
+}
+
+src_install() {
+ sed -e "s:^prefix=.*$:prefix=${D}/usr:" lib/LocalMakefile \
+ > lib/LocalMakefile.foo
+ mv lib/LocalMakefile.foo lib/LocalMakefile
+ use doc && doman ${WORKDIR}/${PN}-man-${PV}/man3/*
+ make install install_devel install_inc
+}