summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 20:31:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 20:31:59 +0000
commit162c0c82c4019bc17f364d56f058b868e21a6e88 (patch)
treedc52bd7e59074013dba682f225cc13be2ad4dea0 /app-shells
parentAdded Gaim text replacement patch, fixes Bug #47012 (diff)
downloadhistorical-162c0c82c4019bc17f364d56f058b868e21a6e88.tar.gz
historical-162c0c82c4019bc17f364d56f058b868e21a6e88.tar.bz2
historical-162c0c82c4019bc17f364d56f058b868e21a6e88.zip
add inherit eutils
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/zsh-4.1.1-r5.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/app-shells/zsh/zsh-4.1.1-r5.ebuild b/app-shells/zsh/zsh-4.1.1-r5.ebuild
index c62932be79a4..f72bb3fc7e63 100644
--- a/app-shells/zsh/zsh-4.1.1-r5.ebuild
+++ b/app-shells/zsh/zsh-4.1.1-r5.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.1.1-r5.ebuild,v 1.4 2004/03/27 17:18:26 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.1.1-r5.ebuild,v 1.5 2004/04/07 20:31:59 vapier Exp $
-IUSE="cjk maildir ncurses static doc"
+inherit flag-o-matic eutils
+MYDATE="20040204"
DESCRIPTION="UNIX Shell similar to the Korn shell"
HOMEPAGE="http://www.zsh.org/"
-
-MYDATE="20040204"
-
SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )
doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
-SLOT="0"
LICENSE="ZSH"
+SLOT="0"
KEYWORDS="x86 alpha ~ppc sparc ~amd64 hppa"
+IUSE="cjk maildir ncurses static doc"
-DEPEND="sys-apps/groff
- >=sys-apps/sed-4
- ${RDEPEND}"
RDEPEND=">=dev-libs/libpcre-3.9
sys-libs/libcap
ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ${RDEPEND}"
src_unpack() {
unpack ${P}.tar.bz2
@@ -44,7 +43,7 @@ src_compile() {
use ncurses && myconf="--with-curses-terminfo"
use maildir && myconf="${myconf} --enable-maildir-support"
use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
+ && append-ldflags -static
econf \
--bindir=/bin \
@@ -61,7 +60,7 @@ src_compile() {
--enable-ldflags="${LDFLAGS}" \
${myconf} || die "configure failed"
- if [ -n "`use static`" ] ; then
+ if use static ; then
# compile all modules statically, see Bug #27392
sed -i -e "s/link=no/link=static/g" \
-e "s/load=no/load=yes/g" \
@@ -95,7 +94,7 @@ src_install() {
dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
- if [ "`use doc`" ] ; then
+ if use doc ; then
dohtml Doc/*
insinto /usr/share/doc/${PF}
doins Doc/zsh{.dvi,_us.ps,_a4.ps}
@@ -109,13 +108,12 @@ pkg_preinst() {
# Our zprofile file does the job of the old zshenv file
# Move the old version into a zprofile script so the normal
# etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
+ if [ -f ${ROOT}/etc/zsh/zshenv -a ! -f ${ROOT}/etc/zsh/zprofile ]; then
+ mv ${ROOT}/etc/zsh/zshenv ${ROOT}/etc/zsh/zprofile
fi
}
pkg_postinst() {
-
# see Bug 26776
ewarn
ewarn "If you are upgrading from zsh-4.0.x you may need to"