summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-05 20:19:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-05 20:19:30 +0000
commit272227010b0045f1275f90cd698034e811c62871 (patch)
tree69a05be45a3ce11a5c44194ce809ecf43446dc07 /app-text/aspell
parentrepoman fixups (diff)
downloadhistorical-272227010b0045f1275f90cd698034e811c62871.tar.gz
historical-272227010b0045f1275f90cd698034e811c62871.tar.bz2
historical-272227010b0045f1275f90cd698034e811c62871.zip
bugfix update
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog11
-rw-r--r--app-text/aspell/aspell-0.50.2.ebuild76
-rw-r--r--app-text/aspell/files/digest-aspell-0.50.21
3 files changed, 87 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index 01a7d0cfbe9b..1853e60aded8 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/aspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.13 2002/09/09 23:29:19 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.14 2002/10/05 20:19:30 seemant Exp $
+
+*aspell-0.50.2 (05 Oct 2002)
+
+ 05 Oct 2002; Seemant Kulleen <seemant@gentoo.org> aspell-0.50.2.ebuild
+ files/digest-aspell-0.50.2 :
+
+ Version bump which fixes a LOT of bugs. Kword and Kmail should now work
+ properly with this. New ebuild notification by: arun@virginia.edu (Arun
+ Thomas) (sindian in #gentoo-dev) in bug #8786.
*aspell-0.50.1 (03 Sep 2002)
diff --git a/app-text/aspell/aspell-0.50.2.ebuild b/app-text/aspell/aspell-0.50.2.ebuild
new file mode 100644
index 000000000000..11f94b8a695d
--- /dev/null
+++ b/app-text/aspell/aspell-0.50.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.2.ebuild,v 1.1 2002/10/05 20:19:30 seemant Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A spell checker replacement for ispell"
+SRC_URI="ftp://ftp.gnu.org/gnu/aspell/${P}.tar.gz"
+HOMEPAGE="http://aspell.net/"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+#
+# These flags a reset here because too much optimisation can cause aspell's
+# compilation process to break. Moreover, these must be set before ./configure
+# otherwise it breaks again. A very fragile build process, really.
+#
+#CXXFLAGS="-O2"
+#CFLAGS=${CXXFLAGS}
+
+# humm .. why are they comented? cselkirk
+
+pkg_setup() {
+ if [ ${ARCH} = "ppc" ] ; then
+ CXXFLAGS="-O2 -fsigned-char"
+ CFLAGS=${CXXFLAGS}
+ fi
+}
+
+src_compile() {
+ elibtoolize
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ cd ${D}/usr/share/doc/${P}
+ dohtml -r man-html
+ rm -rf man-html
+ docinto text
+ dodoc man-text
+ rm -rf man-text
+ cd ${S}
+
+ dodoc README* TODO
+
+ cd examples
+ make clean || die
+ cd ${S}
+
+ docinto examples
+ dodoc examples/*
+
+}
+
+pkg_postinst() {
+
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-i18n category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+}
diff --git a/app-text/aspell/files/digest-aspell-0.50.2 b/app-text/aspell/files/digest-aspell-0.50.2
new file mode 100644
index 000000000000..1c982734c9f8
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.50.2
@@ -0,0 +1 @@
+MD5 d6c3d50c355bc2e6b2f253a1f7209b92 aspell-0.50.2.tar.gz 922061