summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-12 17:03:15 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-12 17:03:15 +0000
commit6e174b5a5a80d5fbae0aa06342904290d2fb8e1c (patch)
tree70b99d01bbed226857c92a3f3ab8265cf9d4dde6 /app-text/poppler-bindings
parentClarify wording of postinst message, thanks to hkbst for suggesting this. (diff)
downloadhistorical-6e174b5a5a80d5fbae0aa06342904290d2fb8e1c.tar.gz
historical-6e174b5a5a80d5fbae0aa06342904290d2fb8e1c.tar.bz2
historical-6e174b5a5a80d5fbae0aa06342904290d2fb8e1c.zip
version bump
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'app-text/poppler-bindings')
-rw-r--r--app-text/poppler-bindings/ChangeLog8
-rw-r--r--app-text/poppler-bindings/files/digest-poppler-bindings-0.6.13
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.6.1.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index f67da32c2cd6..e80bc250098e 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.69 2007/09/06 17:48:22 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.70 2007/10/12 17:03:14 genstef Exp $
+
+*poppler-bindings-0.6.1 (12 Oct 2007)
+
+ 12 Oct 2007; Stefan Schweizer <genstef@gentoo.org>
+ +poppler-bindings-0.6.1.ebuild:
+ version bump
06 Sep 2007; Stefan Schweizer <genstef@gentoo.org>
-files/poppler-0.5.9-bindings.patch, +files/poppler-nocairo.patch,
diff --git a/app-text/poppler-bindings/files/digest-poppler-bindings-0.6.1 b/app-text/poppler-bindings/files/digest-poppler-bindings-0.6.1
new file mode 100644
index 000000000000..713172292ab2
--- /dev/null
+++ b/app-text/poppler-bindings/files/digest-poppler-bindings-0.6.1
@@ -0,0 +1,3 @@
+MD5 78a5f8ff1a3464eddb127577eea7a191 poppler-0.6.1.tar.gz 1286501
+RMD160 19496a6b3a5aeb7eca2f7edc2e957868880a90f4 poppler-0.6.1.tar.gz 1286501
+SHA256 d4fb2789bf880ce82b4f90f9e269409d81a804e7877265610494646e463d3ff2 poppler-0.6.1.tar.gz 1286501
diff --git a/app-text/poppler-bindings/poppler-bindings-0.6.1.ebuild b/app-text/poppler-bindings/poppler-bindings-0.6.1.ebuild
new file mode 100644
index 000000000000..1d92e0350f0d
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.6.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.6.1.ebuild,v 1.1 2007/10/12 17:03:14 genstef Exp $
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt3 cairo qt4"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-0.5 )
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ )
+ qt3? ( =x11-libs/qt-3* )
+ qt4? ( =x11-libs/qt-4* )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/automake-1.9.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf --enable-opi \
+ $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt3 poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}