summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-08-09 23:11:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-08-09 23:11:30 +0000
commit676b4a562ea250bc2c3218ec8d7d3b4c67795b4f (patch)
tree5a719e3ae9aebe822eff89456019c2e1f75a2e41 /dev-cpp
parentYet another security bugfix... (diff)
downloadhistorical-676b4a562ea250bc2c3218ec8d7d3b4c67795b4f.tar.gz
historical-676b4a562ea250bc2c3218ec8d7d3b4c67795b4f.tar.bz2
historical-676b4a562ea250bc2c3218ec8d7d3b4c67795b4f.zip
Version bumped. Bug 59627
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/poslib/ChangeLog7
-rw-r--r--dev-cpp/poslib/Manifest4
-rw-r--r--dev-cpp/poslib/files/digest-poslib-1.0.51
-rw-r--r--dev-cpp/poslib/poslib-1.0.5.ebuild30
4 files changed, 40 insertions, 2 deletions
diff --git a/dev-cpp/poslib/ChangeLog b/dev-cpp/poslib/ChangeLog
index 2786b8b38589..8b4e8b0a7be1 100644
--- a/dev-cpp/poslib/ChangeLog
+++ b/dev-cpp/poslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/poslib
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.8 2004/06/29 15:16:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.9 2004/08/09 23:11:30 matsuu Exp $
+
+*poslib-1.0.5 (10 Aug 2004)
+
+ 10 Aug 2004; MATSUU Takuto <matsuu@gentoo.org> +poslib-1.0.5.ebuild:
+ Version bumped. Bug 59627.
29 Jun 2004; Aron Griffis <agriffis@gentoo.org> poslib-1.0.2.ebuild,
poslib-1.0.4.ebuild:
diff --git a/dev-cpp/poslib/Manifest b/dev-cpp/poslib/Manifest
index f01b7153fc7d..8bf4eb98f80e 100644
--- a/dev-cpp/poslib/Manifest
+++ b/dev-cpp/poslib/Manifest
@@ -1,6 +1,8 @@
MD5 4164b852526c2507f321d91b2ed2780b poslib-1.0.2.ebuild 707
MD5 ef07099279df426d3bd8732f87623ad2 poslib-1.0.4.ebuild 714
-MD5 2d0ff8055910bf9fd5bbd63a588de8b2 ChangeLog 912
+MD5 308e0028f1b5abfff4c90ced8a71e7b1 ChangeLog 1040
MD5 ca160035368973903394d90e1506ff21 metadata.xml 566
+MD5 b493e16dfac7d1f51e445d635c036dfa poslib-1.0.5.ebuild 749
MD5 d26ec63ce97f5c2e14c08762a62ba2f7 files/digest-poslib-1.0.2 64
MD5 6315a7c375173375b5c62450bdf189e2 files/digest-poslib-1.0.4 64
+MD5 493d2924243ec303551d83a251ba508b files/digest-poslib-1.0.5 64
diff --git a/dev-cpp/poslib/files/digest-poslib-1.0.5 b/dev-cpp/poslib/files/digest-poslib-1.0.5
new file mode 100644
index 000000000000..4513c011784d
--- /dev/null
+++ b/dev-cpp/poslib/files/digest-poslib-1.0.5
@@ -0,0 +1 @@
+MD5 9470b991bcaace0b1c00f32cbeda0cff poslib-1.0.5.tar.gz 258380
diff --git a/dev-cpp/poslib/poslib-1.0.5.ebuild b/dev-cpp/poslib/poslib-1.0.5.ebuild
new file mode 100644
index 000000000000..16744f9cf71f
--- /dev/null
+++ b/dev-cpp/poslib/poslib-1.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/poslib-1.0.5.ebuild,v 1.1 2004/08/09 23:11:30 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A library for creating C++ programs using the Domain Name System"
+HOMEPAGE="http://www.posadis.org/projects/poslib.php"
+SRC_URI="mirror://sourceforge/posadis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="ipv6"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ append-flags -funsigned-char
+
+ econf \
+ --with-cxxflags="${CXXFLAGS}" \
+ `use_enable ipv6` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}