summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-06 08:04:42 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-06 08:04:42 +0000
commit81067741db251163546b15b1a4e894372e7f44a4 (patch)
tree700519573308b952dca9956050942936af5b581a /dev-db
parentInitial release of Snd for Gentoo (diff)
downloadhistorical-81067741db251163546b15b1a4e894372e7f44a4.tar.gz
historical-81067741db251163546b15b1a4e894372e7f44a4.tar.bz2
historical-81067741db251163546b15b1a4e894372e7f44a4.zip
new package. Fixes #4430. Contributed by Don Seiler and Sascha Ludecke
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tora/ChangeLog13
-rw-r--r--dev-db/tora/files/digest-tora-1.3.6.11
-rw-r--r--dev-db/tora/files/tora-1.3.6.1.patch10
-rw-r--r--dev-db/tora/tora-1.3.6.1.ebuild44
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
new file mode 100644
index 000000000000..e77115b29158
--- /dev/null
+++ b/dev-db/tora/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-db/tora
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.1 2002/08/06 08:04:42 rphillips Exp $
+
+*unixODBC-2.0.6 (6 Aug 2002)
+
+ 6 Aug 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-db/tora/files/digest-tora-1.3.6.1 b/dev-db/tora/files/digest-tora-1.3.6.1
new file mode 100644
index 000000000000..9a3b605cffc0
--- /dev/null
+++ b/dev-db/tora/files/digest-tora-1.3.6.1
@@ -0,0 +1 @@
+MD5 eba499b4c13da01676870ec7bdda5d58 tora-alpha-1.3.6.1.tar.gz 2269388
diff --git a/dev-db/tora/files/tora-1.3.6.1.patch b/dev-db/tora/files/tora-1.3.6.1.patch
new file mode 100644
index 000000000000..2ed807dfd7f2
--- /dev/null
+++ b/dev-db/tora/files/tora-1.3.6.1.patch
@@ -0,0 +1,10 @@
+--- configure.pl-orig Thu Jul 4 23:02:44 2002
++++ configure.pl Wed Jul 31 13:21:28 2002
+@@ -310,6 +310,7 @@
+ $MySQLFound=0;
+ } elsif (/^--without-oracle$/) {
+ $OracleFound=0;
++ $OracleShared=""
+ } elsif (/^--without-kde$/) {
+ $NoKDE=1;
+ } elsif (/^--enable-onlymake$/) {
diff --git a/dev-db/tora/tora-1.3.6.1.ebuild b/dev-db/tora/tora-1.3.6.1.ebuild
new file mode 100644
index 000000000000..f974e3196ffe
--- /dev/null
+++ b/dev-db/tora/tora-1.3.6.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.6.1.ebuild,v 1.1 2002/08/06 08:04:42 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TOra - Toolkit For Oracle"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+HOMEPAGE="http://www.globecom.se/tora/"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ mysql? ( >=dev-db/mysql-3.23 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+src_compile() {
+ local myconf
+
+ use kde && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use mysql && myconf="$myconf" \
+ || myconf="$myconf --without-mysql"
+# use postgres && myconf="$myconf" \
+# || myconf="$myconf --without-postgres"
+ use oci8 && myconf="$myconf" \
+ || myconf="$myconf --without-oracle"
+
+ patch -p0 < ${FILESDIR}/tora-${PV}.patch
+
+ ./configure \
+ --prefix=/usr \
+ --with-mono \
+ $myconf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir ${D}/usr/bin
+ make \
+ ROOT=${D} \
+ install || die "make install failed"
+}