summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-13 03:13:41 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-13 03:13:41 +0000
commit164c9cd8bf2f7eaff2fb4d6376959e6916804611 (patch)
tree09d87bb1182d8bb6a971fbe91437be28dc001738 /dev-games/crystalspace
parentadd skk-jisyo-cdb-200307.ebuild(update) (diff)
downloadhistorical-164c9cd8bf2f7eaff2fb4d6376959e6916804611.tar.gz
historical-164c9cd8bf2f7eaff2fb4d6376959e6916804611.tar.bz2
historical-164c9cd8bf2f7eaff2fb4d6376959e6916804611.zip
welcome to dev-games
Diffstat (limited to 'dev-games/crystalspace')
-rw-r--r--dev-games/crystalspace/ChangeLog21
-rw-r--r--dev-games/crystalspace/Manifest3
-rw-r--r--dev-games/crystalspace/crystalspace-20030413-r1.ebuild48
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-20030413-r11
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
new file mode 100644
index 000000000000..f01f294909cf
--- /dev/null
+++ b/dev-games/crystalspace/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for dev-libs/crystalspace
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.1 2003/07/13 03:13:40 vapier Exp $
+
+*crystalspace-20030413-r1 (17 Apr 2003)
+
+ 17 Apr 2003; Philip Walls <malverian@gentoo.org>
+ crystalspace-20030413-r1.ebuild :
+ Fixed problem with env.d/15crystalspace (vars now on seperate lines)
+
+*crystalspace-20030413 (13 Apr 2003)
+
+ 13 Apr 2003; Philip Walls <malverian@gentoo.org>
+ crystalspace-20030413.ebuild :
+ CrystalSpace snapshot that works with Planeshift
+
+*crystalspace-0.96_p002 (02 Apr 2003)
+
+ 02 Apr 2003; Philip Walls <malverian@gentoo.org>
+ crystalspace-0.96_p002.ebuild :
+ Initial import. Thanks to lu_zero for testing and original ebuild.
diff --git a/dev-games/crystalspace/Manifest b/dev-games/crystalspace/Manifest
new file mode 100644
index 000000000000..8905fd1caee5
--- /dev/null
+++ b/dev-games/crystalspace/Manifest
@@ -0,0 +1,3 @@
+MD5 a8d429711d81b9c10a2b4d7fa0db2b9c ChangeLog 786
+MD5 77f856190624eae36fc08c678da9b07d crystalspace-20030413-r1.ebuild 1255
+MD5 d90edc320c9f4398c1e5c528569f8706 files/digest-crystalspace-20030413-r1 75
diff --git a/dev-games/crystalspace/crystalspace-20030413-r1.ebuild b/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
new file mode 100644
index 000000000000..c5e01eb35421
--- /dev/null
+++ b/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-20030413-r1.ebuild,v 1.1 2003/07/13 03:13:40 vapier Exp $
+
+inherit games
+
+DESCRIPTION="portable 3D Game Development Kit written in C++"
+SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
+HOMEPAGE="http://crystal.sourceforge.net/"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+IUSE="oggvorbis mikmod openal freetype 3ds mng"
+
+DEPEND=">=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ mng? ( media-libs/libmng )
+ mikmod? ( media-libs/libmikmod )
+ 3ds? ( media-libs/lib3ds )
+ freetype? ( >=media-libs/freetype-2.0 )
+ openal? ( media-libs/openal )
+ zlib? ( sys-libs/zlib )
+ oggvorbis? ( >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ x86? ( dev-lang/nasm )
+ dev-libs/ode
+ >=dev-lang/perl-5.6.1
+ !dev-libs/crystalspace-cvs"
+
+S=${WORKDIR}/CS
+
+CRYSTAL_PREFIX=${GAMES_PREFIX_OPT}/crystal
+
+src_compile() {
+ ./configure --prefix=${CRYSTAL_PREFIX} || die
+ make all || die
+}
+
+src_install() {
+ dodir ${CRYSTAL_PREFIX}
+ make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
+
+ dodir ${GAMES_BINDIR}
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config ${GAMES_BINDIR}/cs-config
+
+ prepgamesdirs
+}
diff --git a/dev-games/crystalspace/files/digest-crystalspace-20030413-r1 b/dev-games/crystalspace/files/digest-crystalspace-20030413-r1
new file mode 100644
index 000000000000..76ed9c7b75de
--- /dev/null
+++ b/dev-games/crystalspace/files/digest-crystalspace-20030413-r1
@@ -0,0 +1 @@
+MD5 4f1791a51d929ff14766e596b0a80841 crystalspace-20030413.tar.gz 17033685