summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-14 16:32:25 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-14 16:32:25 +0000
commit35b0523403120802576559eb9fe55e1bd94e872f (patch)
tree21b267b285f4075ecf5b0079a04c048c58bc9b3a /dev-haskell/dav/dav-0.6.1.ebuild
parentnew version, bug #504602 (diff)
downloadhistorical-35b0523403120802576559eb9fe55e1bd94e872f.tar.gz
historical-35b0523403120802576559eb9fe55e1bd94e872f.tar.bz2
historical-35b0523403120802576559eb9fe55e1bd94e872f.zip
bump new versions, bug #504602
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xEAD50D64D8D3571A!
Diffstat (limited to 'dev-haskell/dav/dav-0.6.1.ebuild')
-rw-r--r--dev-haskell/dav/dav-0.6.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/dav/dav-0.6.1.ebuild b/dev-haskell/dav/dav-0.6.1.ebuild
new file mode 100644
index 000000000000..8857cf20cd70
--- /dev/null
+++ b/dev-haskell/dav/dav-0.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/dav-0.6.1.ebuild,v 1.1 2014/03/14 16:32:23 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="DAV"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="RFC 4918 WebDAV support"
+HOMEPAGE="http://floss.scru.org/hDAV"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
+ >=dev-haskell/either-4.1:=[profile?]
+ dev-haskell/errors:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ >=dev-haskell/http-client-tls-0.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lens-3.0:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/optparse-applicative-0.5.0:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?] <=dev-haskell/xml-conduit-1.2:=[profile?]
+ >=dev-haskell/xml-hamlet-0.4:=[profile?] <=dev-haskell/xml-hamlet-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"