summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-16 09:52:04 +0000
committerMark Wright <gienah@gentoo.org>2012-06-16 09:52:04 +0000
commit2e637f03c03ce1f9f13969d600af45468fdd248b (patch)
treefa767a16c122e67c2c6c2208443065e800d6770a /dev-haskell/haxml
parentAdd polyparse for haxml 1.23 (diff)
downloadhistorical-2e637f03c03ce1f9f13969d600af45468fdd248b.tar.gz
historical-2e637f03c03ce1f9f13969d600af45468fdd248b.tar.bz2
historical-2e637f03c03ce1f9f13969d600af45468fdd248b.zip
Bump haxml to 1.23
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/haxml')
-rw-r--r--dev-haskell/haxml/ChangeLog11
-rw-r--r--dev-haskell/haxml/files/haxml-1.23-fix-build.patch85
-rw-r--r--dev-haskell/haxml/files/haxml-1.23-haddock.patch37
-rw-r--r--dev-haskell/haxml/haxml-1.23.ebuild30
4 files changed, 161 insertions, 2 deletions
diff --git a/dev-haskell/haxml/ChangeLog b/dev-haskell/haxml/ChangeLog
index 30ad4a719b29..b87b4dff5844 100644
--- a/dev-haskell/haxml/ChangeLog
+++ b/dev-haskell/haxml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/haxml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.29 2011/06/05 13:00:33 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.30 2012/06/16 09:52:04 gienah Exp $
+
+*haxml-1.23 (16 Jun 2012)
+
+ 16 Jun 2012; Mark Wright <gienah@gentoo.org>
+ +files/haxml-1.23-fix-build.patch, +files/haxml-1.23-haddock.patch,
+ +haxml-1.23.ebuild:
+ Bump haxml to 1.23
05 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org> -haxml-1.12.ebuild,
-files/HaXml-1.12.cabal, -haxml-1.13-r1.ebuild:
diff --git a/dev-haskell/haxml/files/haxml-1.23-fix-build.patch b/dev-haskell/haxml/files/haxml-1.23-fix-build.patch
new file mode 100644
index 000000000000..4ba6259b6908
--- /dev/null
+++ b/dev-haskell/haxml/files/haxml-1.23-fix-build.patch
@@ -0,0 +1,85 @@
+--- HaXml-1.23-orig/HaXml.cabal 2012-06-15 21:27:50.000000000 +1000
++++ HaXml-1.23/HaXml.cabal 2012-06-16 17:18:02.471555934 +1000
+@@ -11,7 +11,7 @@
+ Haskell utilities for parsing, filtering, transforming and
+ generating XML documents.
+ build-type: Simple
+-cabal-version: >=1.2
++cabal-version: >=1.8
+ extra-source-files: LICENCE-GPL, LICENCE-LGPL
+
+ flag splitBase
+@@ -84,6 +84,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: Canonicalise.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable CanonicaliseLazy
+ GHC-Options: -Wall
+@@ -91,6 +92,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: CanonicaliseLazy.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable Xtract
+ GHC-Options: -Wall
+@@ -98,6 +100,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: Xtract.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable Validate
+ GHC-Options: -Wall
+@@ -105,6 +108,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: Validate.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable MkOneOf
+ GHC-Options: -Wall
+@@ -112,6 +116,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: MkOneOf.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable DtdToHaskell
+ GHC-Options: -Wall
+@@ -119,6 +124,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: DtdToHaskell.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable XsdToHaskell
+ GHC-Options: -Wall
+@@ -126,6 +132,7 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: XsdToHaskell.hs
++ build-depends: base, bytestring, containers, filepath, polyparse >= 1.5, pretty
+
+ Executable FpMLToHaskell
+ GHC-Options: -Wall
+@@ -133,5 +140,5 @@
+ Hs-Source-Dirs: src/tools, src
+ cpp-options: -DMAJOR=1 -DMINOR=23
+ Main-Is: FpMLToHaskell.hs
+- build-depends: directory
++ build-depends: base, bytestring, containers, directory, filepath, HaXml == 1.23.*, polyparse >= 1.5, pretty
+
+--- HaXml-1.23-orig/src/tools/FpMLToHaskell.hs 2012-06-15 21:27:50.000000000 +1000
++++ HaXml-1.23/src/tools/FpMLToHaskell.hs 2012-06-16 16:22:22.423493642 +1000
+@@ -33,7 +33,7 @@
+ import Text.XML.HaXml.Schema.Environment as Env
+ import Text.XML.HaXml.Schema.TypeConversion as XsdToH
+ import Text.XML.HaXml.Schema.PrettyHaskell
+-import qualified Text.XML.HaXml.Schema.PrettyHsBoot as HsBoot
++import qualified Text.XML.HaXml.Schema.PrettyHaskell as HsBoot
+ import qualified Text.XML.HaXml.Schema.HaskellTypeModel as Haskell
+ import Text.ParserCombinators.Poly
+ import Text.PrettyPrint.HughesPJ (render,vcat)
diff --git a/dev-haskell/haxml/files/haxml-1.23-haddock.patch b/dev-haskell/haxml/files/haxml-1.23-haddock.patch
new file mode 100644
index 000000000000..8c52465d8533
--- /dev/null
+++ b/dev-haskell/haxml/files/haxml-1.23-haddock.patch
@@ -0,0 +1,37 @@
+--- HaXml-1.23-orig/src/Text/XML/HaXml/Schema/HaskellTypeModel.hs 2012-06-15 21:27:49.000000000 +1000
++++ HaXml-1.23/src/Text/XML/HaXml/Schema/HaskellTypeModel.hs 2012-06-16 16:46:26.358651992 +1000
+@@ -77,8 +77,8 @@
+ -- rests with the input doc, not with the caller of the parser.
+ | ElementsAttrsAbstract {-typename-}XName
+ {-subtypes-}[(XName,Maybe XName)]
+- -- ^ [(type name, module where declared later)]
+ Comment
++ -- ^ [(type name, module where declared later)]
+
+ -- becomes function
+ -- elementE :: Parser T
+--- HaXml-1.23-orig/src/Text/XML/HaXml/Schema/PrettyHaskell.hs 2012-06-15 21:27:50.000000000 +1000
++++ HaXml-1.23/src/Text/XML/HaXml/Schema/PrettyHaskell.hs 2012-06-16 16:49:56.952051977 +1000
+@@ -403,9 +403,6 @@
+ $$ text "data" <+> ppUnqConId nx t
+ $$ nest 8 (ppvList "=" "|" "" ppAbstrCons insts
+ $$ text "deriving (Eq,Show)")
+--- $$ text "-- instance SchemaType" <+> ppUnqConId nx t
+--- <+> text "(declared in Instance module)"
+--- *** Declare instance here
+ $$ text "instance SchemaType" <+> ppUnqConId nx t <+> text "where"
+ $$ nest 4 (text "parseSchemaType s = do"
+ $$ nest 4 (vcat (intersperse (text "`onFail`")
+@@ -417,12 +414,6 @@
+ where
+ ppAbstrCons (name,Nothing) = con name <+> ppConId nx name
+ ppAbstrCons (name,Just mod) = con name <+> ppConId nx name
+--- *** Declare FwdDecl type here (proxy for type declared in later module)
+--- ppAbstrCons (name,Just mod) = text "forall q . (FwdDecl" <+>
+--- fwd name <+> text "q," <+>
+--- text "SchemaType q) =>" <+>
+--- con name <+>
+--- text "("<>fwd name<>text"->q)" <+> fwd name
+ ppParse (name,Nothing) = text "(fmap" <+> con name <+>
+ text "$ parseSchemaType s)"
+ ppParse (name,Just _) = ppParse (name,Nothing)
diff --git a/dev-haskell/haxml/haxml-1.23.ebuild b/dev-haskell/haxml/haxml-1.23.ebuild
new file mode 100644
index 000000000000..f274c79d0061
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.23.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.23.ebuild,v 1.1 2012/06/16 09:52:04 gienah Exp $
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/HaXml/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT=0
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.5[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-1.23-fix-build.patch"
+ "${FILESDIR}/${PN}-1.23-haddock.patch")